{"answers":{"affected":"8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7038 in the wild and no public exploit code.","fix":"Upgrade moodle/moodle to a fixed version for your release line: 2.7.16, 2.9.8, 3.0.6 or 3.1.2.","what":"CVE-2016-7038 is a high-severity vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7038 and fix it if it is affected.\n\nWhat it is: CVE-2016-7038 is a high-severity vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7038 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.16\n- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.16\n- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.8\n- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.8\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.6\n- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.6\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.2\n- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7038/ (Markdown: https://insights.sbomify.com/CVE-2016-7038/index.md)","id":"CVE-2016-7038","markdown":"https://insights.sbomify.com/CVE-2016-7038/index.md","name":"CVE-2016-7038","record":{"aliases":["GHSA-2phx-w35g-x9vm","UBUNTU-CVE-2016-7038"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Moodle LMS","requires_auth":"none","summary":"Attackers can retain access via old web service tokens after a user password change, bypassing security controls in Moodle.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"moodle","vendor":"moodle"}],"cvss":{"score":7.3,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-640","name":"Weak Password Recovery Mechanism for Forgotten Password"}],"description":"In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moodle Weak Password Recovery Mechanism for Forgotten Password","id":"CVE-2016-7038","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"moodle:moodle","products":["moodle:moodle"],"type":"security_feature_bypass","year":"2016"},"n_packages":8,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-7039"},"packages":[{"ecosystem":"Packagist","fixed":["2.7.16"],"introduced":["2.7"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["2.7.16"],"introduced":["2.7"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["2.9.8"],"introduced":["2.9"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["2.9.8"],"introduced":["2.9"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["3.0.6"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["3.0.6"],"introduced":["3.0"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":null,"source":"GHSA-2phx-w35g-x9vm"},{"ecosystem":"Packagist","fixed":["3.1.2"],"introduced":["3.1"],"last_affected":[],"package":"moodle/moodle","purl":"pkg:composer/moodle/moodle","source":"GHSA-2phx-w35g-x9vm"}],"prev":{"headline":"Security feature bypass in n/a","id":"CVE-2016-7037"},"products":["Moodle 2.x and 3.x"],"published":"2017-01-20","related":[{"cvss_score":10,"headline":"File upload in n/a","id":"CVE-2006-4935","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Moodle does not properly validate module instance id","id":"CVE-2006-4936","kev_date_added":null,"published":"2006-09-23"},{"cvss_score":10,"headline":"Unknown \"front page vulnerability with Moodle servers\" for Moodle before 1.3.2 has unknown impact and attack vectors.","id":"CVE-2004-2233","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Cross-site scripting in n/a","id":"CVE-2004-2235","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2004-2236","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Unknown vulnerability in Moodle before 1.3.4 has unknown impact and attack vectors, related to \"strings in Moodle texts.\"","id":"CVE-2004-2237","kev_date_added":null,"published":"2005-07-17"},{"cvss_score":10,"headline":"Multiple unknown vulnerabilities in Moodle before 1.5.1 have unknown impact and attack vectors.","id":"CVE-2005-2247","kev_date_added":null,"published":"2005-07-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can retain access via old web service tokens after a user password change, bypassing security controls in Moodle.","url":"https://insights.sbomify.com/CVE-2016-7038/"}