# CVE-2016-7038: Moodle Weak Password Recovery Mechanism for Forgotten Password

> Attackers can retain access via old web service tokens after a user password change, bypassing security controls in Moodle.

- **Severity:** High 7.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-2phx-w35g-x9vm, UBUNTU-CVE-2016-7038

## What is CVE-2016-7038?

CVE-2016-7038 is a high-severity vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

In Moodle 2.x and 3.x, web service tokens are not invalidated when the user password is changed or forced to be changed.

Weakness: CWE-640 (Weak Password Recovery Mechanism for Forgotten Password)

## Which versions are affected by CVE-2016-7038?

8 open source packages ship an affected version, including moodle/moodle. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moodle/moodle` | Packagist | From 2.7 | 2.7.16 |
| `moodle/moodle` | Packagist | From 2.7 | 2.7.16 |
| `moodle/moodle` | Packagist | From 2.9 | 2.9.8 |
| `moodle/moodle` | Packagist | From 2.9 | 2.9.8 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.6 |
| `moodle/moodle` | Packagist | From 3.0 | 3.0.6 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.2 |
| `moodle/moodle` | Packagist | From 3.1 | 3.1.2 |

Products: Moodle Moodle.

## How do I fix CVE-2016-7038?

Upgrade moodle/moodle to a fixed version for your release line: 2.7.16, 2.9.8, 3.0.6 or 3.1.2.

## Is CVE-2016-7038 being exploited?

There is no known exploitation of CVE-2016-7038 in the wild and no public exploit code.

## Other vulnerabilities in Moodle Moodle

- [CVE-2006-4935](https://insights.sbomify.com/CVE-2006-4935/): File upload in n/a (critical 10.0)
- [CVE-2006-4936](https://insights.sbomify.com/CVE-2006-4936/): Moodle does not properly validate module instance id (critical 10.0)
- [CVE-2004-2233](https://insights.sbomify.com/CVE-2004-2233/): Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors. (critical 10.0)
- [CVE-2004-2235](https://insights.sbomify.com/CVE-2004-2235/): Cross-site scripting in n/a (critical 10.0)
- [CVE-2004-2236](https://insights.sbomify.com/CVE-2004-2236/): Other in n/a (critical 10.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7038 and fix it if it is affected.

What it is: CVE-2016-7038 is a high-severity vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7038 in the wild and no public exploit code.

Affected packages and fixed versions:
- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.16
- moodle/moodle (Packagist): affected from 2.7; fixed in 2.7.16
- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.8
- moodle/moodle (Packagist): affected from 2.9; fixed in 2.9.8
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.6
- moodle/moodle (Packagist): affected from 3.0; fixed in 3.0.6
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.2
- moodle/moodle (Packagist): affected from 3.1; fixed in 3.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7038/ (Markdown: https://insights.sbomify.com/CVE-2016-7038/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7038
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7038
- OSV: https://osv.dev/vulnerability/CVE-2016-7038

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7038/
Summaries are generated and may contain mistakes; the official description above is the record.
