{"answers":{"affected":"It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-7098 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2016-7098 is a high-severity vulnerability in n/a, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7098 and fix it if it is affected.\n\nWhat it is: CVE-2016-7098 is a high-severity vulnerability in n/a, published on 26 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2016-7098 exists.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7098/ (Markdown: https://insights.sbomify.com/CVE-2016-7098/index.md)","id":"CVE-2016-7098","markdown":"https://insights.sbomify.com/CVE-2016-7098/index.md","name":"CVE-2016-7098","record":{"aliases":["DEBIAN-CVE-2016-7098","DLA-2086-1","GHSA-57mm-2gj4-2977","SUSE-SU-2016:3268-1","UBUNTU-CVE-2016-7098"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"wget command line tool","requires_auth":"none","summary":"Remote servers can bypass access list restrictions in wget during recursive downloads by keeping HTTP connections open, requiring an upgrade to mitigate.","user_interaction":"not_required","vuln_class":"race_condition"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"wget","vendor":"gnu"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-362","name":"Concurrent Execution using Shared Resource with Improper Synchronization"}],"description":"Race condition in wget 1.17 and earlier, when used in recursive or mirroring mode to download a single file, might allow remote servers to bypass intended access list restrictions by keeping an HTTP connection open.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Desktop 12 SP2","SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 12 SP2"],"exploits":{"exploitdb":1,"first_seen":"2016-11-24","github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-11-24","kind":"exploitdb","ref":"40824","stars":null,"title":"GNU Wget \u003c 1.18 - Access List Bypass / Race Condition"}],"tier":"weaponised"},"has_fix":true,"headline":"Race condition in n/a","id":"CVE-2016-7098","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"race_condition","year":"2016"},"n_packages":7,"n_references":8,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2016-7099"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP2","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP2","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20Raspberry%20Pi%2012%20SP2","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2016:3268-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["1.14-17.1"],"introduced":["0"],"last_affected":[],"package":"wget","purl":"pkg:rpm/suse/wget\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2016:3268-1"}],"prev":{"headline":"Privilege escalation in n/a","id":"CVE-2016-7097"},"products":["n/a"],"published":"2016-09-26","related":[{"cvss_score":9.8,"headline":"Memory corruption in GNU Wget","id":"CVE-2019-5953","kev_date_added":null,"published":"2019-05-17"},{"cvss_score":9.3,"headline":"Path traversal in n/a","id":"CVE-2014-4877","kev_date_added":null,"published":"2014-10-29"},{"cvss_score":9.1,"headline":"Other in n/a","id":"CVE-2024-38428","kev_date_added":null,"published":"2024-06-16"},{"cvss_score":8.7,"headline":"GNU Wget 1.25.0 Heap Buffer Underread via Metalink URL Parsing","id":"CVE-2026-58469","kev_date_added":null,"published":"2026-07-07"},{"cvss_score":7.8,"headline":"Information disclosure in n/a","id":"CVE-2018-20483","kev_date_added":null,"published":"2018-12-26"},{"cvss_score":6.9,"headline":"GNU Wget 1.25.0 Integer Overflow via Content-Range Header Parsing","id":"CVE-2026-58470","kev_date_added":null,"published":"2026-07-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote servers can bypass access list restrictions in wget during recursive downloads by keeping HTTP connections open, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2016-7098/"}