# CVE-2016-7103: jQuery-UI vulnerable to Cross-site Scripting in dialog closeText

> Remote attackers can inject arbitrary web script or HTML via the closeText parameter in jQuery UI dialog functions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 15 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** CLEANSTART-2024-EC59064, DEBIAN-CVE-2016-7103, GHSA-hpcf-8vf9-q4gj, RHSA-2016:2932, RHSA-2016:2933, RHSA-2017:0161, SUSE-SU-2017:2351-1, UBUNTU-CVE-2016-7103, openSUSE-SU-2024:11214-1, openSUSE-SU-2024:14131-1, openSUSE-SU-2026:11997-1

## What is CVE-2016-7103?

CVE-2016-7103 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in jQuery UI before 1.12.0 might allow remote attackers to inject arbitrary web script or HTML via the closeText parameter of the dialog function.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-7103?

8 open source packages ship an affected version, including org.webjars.npm:jquery-ui, jQuery.UI.Combined and jquery-ui-rails. It affects 13 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.webjars.npm:jquery-ui` | Maven | All versions | 1.12.0 |
| `org.webjars.npm:jquery-ui` | Maven | All versions | 1.12.0 |
| `jQuery.UI.Combined` | NuGet | All versions | 1.12.0 |
| `jQuery.UI.Combined` | NuGet | All versions | 1.12.0 |
| `jquery-ui-rails` | RubyGems | All versions | 6.0.0 |
| `jquery-ui-rails` | RubyGems | All versions | 6.0.0 |
| `jquery-ui` | npm | All versions | 1.12.0 |
| `jquery-ui` | npm | All versions | 1.12.0 |
| `python-XStatic-jquery-ui` | Red Hat:openstack:7::el7 | All versions | 0:1.12.0.1-1.el7ost |
| `python-XStatic-jquery-ui` | Red Hat:openstack:8::el7 | All versions | 0:1.12.0.1-1.el7ost |
| `python-XStatic-jquery-ui` | Red Hat:openstack:9::el7 | All versions | 0:1.12.0.1-1.el7ost |
| `python-XStatic-jquery-ui` | SUSE:OpenStack Cloud 7 | All versions | 1.11.0.1-2.3.1 |
| `python-XStatic-jquery-ui` | openSUSE:Tumbleweed | All versions | 1.13.0.1-1.15 |
| `python-XStatic-jquery-ui` | openSUSE:Tumbleweed | All versions | 1.13.0.1-2.4 |

Products: Debian Debian Linux, Fedoraproject Fedora, Jqueryui Jquery Ui, Juniper Junos, Netapp Snapcenter, Oracle Application Express, Oracle Business Intelligence, Oracle Hospitality Cruise Fleet Management, Oracle Oss Support Tools, Oracle Primavera Unifier, Oracle Siebel Ui Framework, Oracle Weblogic Server, Redhat Openstack.

## How do I fix CVE-2016-7103?

Upgrade org.webjars.npm:jquery-ui to 1.12.0 or later.

## Is CVE-2016-7103 being exploited?

There is no known exploitation of CVE-2016-7103 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7103 and fix it if it is affected.

What it is: CVE-2016-7103 is a medium-severity cross-site scripting vulnerability in Debian Debian Linux, published on 15 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-7103 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.webjars.npm:jquery-ui (Maven): affected all versions; fixed in 1.12.0
- org.webjars.npm:jquery-ui (Maven): affected all versions; fixed in 1.12.0
- jQuery.UI.Combined (NuGet): affected all versions; fixed in 1.12.0
- jQuery.UI.Combined (NuGet): affected all versions; fixed in 1.12.0
- jquery-ui-rails (RubyGems): affected all versions; fixed in 6.0.0
- jquery-ui-rails (RubyGems): affected all versions; fixed in 6.0.0
- jquery-ui (npm): affected all versions; fixed in 1.12.0
- jquery-ui (npm): affected all versions; fixed in 1.12.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7103/ (Markdown: https://insights.sbomify.com/CVE-2016-7103/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7103
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7103
- OSV: https://osv.dev/vulnerability/CVE-2016-7103

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7103/
Summaries are generated and may contain mistakes; the official description above is the record.
