CVE-2016-7111 MantisBT XSS through weak CSP when using Gravatar plugin

Medium 4.7 Published Updated

Remote attackers can execute cross-site scripting attacks in MantisBT when the Gravatar plugin is enabled due to a weak Content Security Policy.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2016-7111?

CVE-2016-7111 is a medium-severity cross-site scripting vulnerability in Mantisbt Mantisbt, published on 17 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

MantisBT before 1.3.1 and 2.x before 2.0.0-beta.2 uses a weak Content Security Policy when using the Gravatar plugin, which allows remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors.

Weakness: CWE-79

Which versions are affected by CVE-2016-7111?

4 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.

PackageAffectedFixed in
mantisbt/mantisbt PackagistAll versions1.3.1
mantisbt/mantisbt PackagistAll versions1.3.1
mantisbt/mantisbt PackagistFrom 2.0.0-beta.12.0.0-beta.2
mantisbt/mantisbt PackagistFrom 2.0.0-beta.12.0.0-beta.2

Products include Mantisbt Mantisbt.

How do I fix CVE-2016-7111?

Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.1 or 2.0.0-beta.2.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2016-7111 being exploited?

There is no known exploitation of CVE-2016-7111 in the wild and no public exploit code.

All Mantisbt Mantisbt vulnerabilities

Sources

Also known as GHSA-8vx9-hcvq-gfv8.

Is CVE-2016-7111 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free