{"answers":{"affected":"4 open source packages ship an affected version, including mantisbt/mantisbt. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7111 in the wild and no public exploit code.","fix":"Upgrade mantisbt/mantisbt to a fixed version for your release line: 1.3.1 or 2.0.0-beta.2.","what":"CVE-2016-7111 is a medium-severity cross-site scripting vulnerability in Mantisbt Mantisbt, published on 17 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-7111 and fix it if it is affected.\n\nWhat it is: CVE-2016-7111 is a medium-severity cross-site scripting vulnerability in Mantisbt Mantisbt, published on 17 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-7111 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.1\n- mantisbt/mantisbt (Packagist): affected all versions; fixed in 1.3.1\n- mantisbt/mantisbt (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-beta.2\n- mantisbt/mantisbt (Packagist): affected from 2.0.0-beta.1; fixed in 2.0.0-beta.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7111/ (Markdown: https://insights.sbomify.com/CVE-2016-7111/index.md)","id":"CVE-2016-7111","markdown":"https://insights.sbomify.com/CVE-2016-7111/index.md","name":"CVE-2016-7111","record":{"aliases":["GHSA-8vx9-hcvq-gfv8"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":true,"product_category":"MantisBT bug tracker","requires_auth":"none","summary":"Remote attackers can execute cross-site scripting attacks in MantisBT when the Gravatar plugin is enabled due to a weak Content Security Policy.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"mantisbt","vendor":"mantisbt"}],"cvss":{"score":4.7,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"MantisBT before 1.3.1 and 2.x before 2.0.0-beta.2 uses a weak Content Security Policy when using the Gravatar plugin, which allows remote attackers to conduct cross-site scripting (XSS) attacks via unspecified vectors.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"MantisBT XSS through weak CSP when using Gravatar plugin","id":"CVE-2016-7111","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"mantisbt:mantisbt","products":["mantisbt:mantisbt"],"type":"xss","year":"2016"},"n_packages":4,"n_references":4,"next":{"headline":"Auth bypass in n/a","id":"CVE-2016-7112"},"packages":[{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"mantisbt/mantisbt","purl":null,"source":"GHSA-8vx9-hcvq-gfv8"},{"ecosystem":"Packagist","fixed":["1.3.1"],"introduced":["0"],"last_affected":[],"package":"mantisbt/mantisbt","purl":"pkg:composer/mantisbt/mantisbt","source":"GHSA-8vx9-hcvq-gfv8"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["2.0.0-beta.1"],"last_affected":[],"package":"mantisbt/mantisbt","purl":null,"source":"GHSA-8vx9-hcvq-gfv8"},{"ecosystem":"Packagist","fixed":["2.0.0-beta.2"],"introduced":["2.0.0-beta.1"],"last_affected":[],"package":"mantisbt/mantisbt","purl":"pkg:composer/mantisbt/mantisbt","source":"GHSA-8vx9-hcvq-gfv8"}],"prev":{"headline":"Command injection in n/a","id":"CVE-2016-7110"},"products":["n/a"],"published":"2017-02-17","related":[{"cvss_score":9.6,"headline":"MantisBT allows cross-site scripting (XSS) via crafted filename","id":"CVE-2019-15074","kev_date_added":null,"published":"2019-08-21"},{"cvss_score":9.3,"headline":"MantisBT SOAP API has an authentication bypass vulnerability on MySQL","id":"CVE-2026-30849","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.8,"headline":"MantisBT: Authentication bypass for some passwords due to PHP type juggling","id":"CVE-2025-47776","kev_date_added":null,"published":"2025-11-04"},{"cvss_score":8.8,"headline":"MantisBT allows arbitrary password reset","id":"CVE-2017-7615","kev_date_added":null,"published":"2017-04-16"},{"cvss_score":8.6,"headline":"MantisBT Vulnerable to Stored HTML Injection in Tag Delete Confirmation","id":"CVE-2026-33517","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.6,"headline":"MantisBT has Stored HTML Injection / XSS when displaying Tags in Timeline","id":"CVE-2026-33548","kev_date_added":null,"published":"2026-03-23"},{"cvss_score":8.3,"headline":"MantisBT Host Header Injection vulnerability","id":"CVE-2024-23830","kev_date_added":null,"published":"2024-02-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute cross-site scripting attacks in MantisBT when the Gravatar plugin is enabled due to a weak Content Security Policy.","url":"https://insights.sbomify.com/CVE-2016-7111/"}