{"answers":{"affected":"2 open source packages ship an affected version, including DotNetNuke.Core. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7119 in the wild and no public exploit code.","fix":"Upgrade DotNetNuke.Core to 8.0.1 or later.","what":"CVE-2016-7119 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 31 Aug 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-7119 and fix it if it is affected.\n\nWhat it is: CVE-2016-7119 is a medium-severity cross-site scripting vulnerability in Dnnsoftware Dotnetnuke, published on 31 Aug 2016. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-7119 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 8.0.1\n- DotNetNuke.Core (NuGet): affected all versions; fixed in 8.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7119/ (Markdown: https://insights.sbomify.com/CVE-2016-7119/index.md)","id":"CVE-2016-7119","markdown":"https://insights.sbomify.com/CVE-2016-7119/index.md","name":"CVE-2016-7119","record":{"aliases":["GHSA-5c66-x4wm-rjfx"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"DotNetNuke CMS","requires_auth":"low_privilege","summary":"Authenticated users can inject arbitrary scripts via the user-profile biography section, potentially leading to session hijacking or malicious actions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"dotnetnuke","vendor":"dnnsoftware"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the user-profile biography section in DotNetNuke (DNN) before 8.0.1 allows remote authenticated users to inject arbitrary web script or HTML via a crafted onclick attribute in an IMG element.","ecosystems":["NuGet"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cross-site scripting (XSS) vulnerability in the user-profile biography section in DotNetNuke (DNN)","id":"CVE-2016-7119","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"NuGet","product":"dnnsoftware:dotnetnuke","products":["dnnsoftware:dotnetnuke"],"type":"xss","year":"2016"},"n_packages":2,"n_references":2,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-7122"},"packages":[{"ecosystem":"NuGet","fixed":["8.0.1"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":null,"source":"GHSA-5c66-x4wm-rjfx"},{"ecosystem":"NuGet","fixed":["8.0.1"],"introduced":["0"],"last_affected":[],"package":"DotNetNuke.Core","purl":"pkg:nuget/DotNetNuke.Core","source":"GHSA-5c66-x4wm-rjfx"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2016-7118"},"products":["n/a"],"published":"2016-08-31","related":[{"cvss_score":8.8,"headline":"DotNetNuke (DNN) Remote Code Execution","id":"CVE-2017-9822","kev_date_added":"2021-11-03","published":"2017-07-20"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-15811","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":7.5,"headline":"DotNetNuke (DNN) Inadequate Encryption Strength","id":"CVE-2018-18325","kev_date_added":"2021-11-03","published":"2019-07-03"},{"cvss_score":10,"headline":"DNN Insufficient Access Control - Image Upload allows for Site Content Overwrite","id":"CVE-2025-64095","kev_date_added":null,"published":"2025-10-28"},{"cvss_score":10,"headline":"Privilege escalation in n/a","id":"CVE-2006-3601","kev_date_added":null,"published":"2006-07-14"},{"cvss_score":9.8,"headline":"The installation wizard in DotNetNuke (DNN) allows privilege escalation","id":"CVE-2015-2794","kev_date_added":null,"published":"2017-02-06"},{"cvss_score":9.1,"headline":"DotNetNuke.Core Vulnerable to Stored XSS via Module Title","id":"CVE-2026-24838","kev_date_added":null,"published":"2026-01-27"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Authenticated users can inject arbitrary scripts via the user-profile biography section, potentially leading to session hijacking or malicious actions.","url":"https://insights.sbomify.com/CVE-2016-7119/"}