# CVE-2016-7135: Plone vulnerable to filesystem information leak

> Remote administrators can read arbitrary files via path traversal in Plone CMS file manager actions.

- **Severity:** Medium 4.9 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 7 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-m7f9-65wr-pwch, PYSEC-2017-58

## What is CVE-2016-7135?

CVE-2016-7135 is a medium-severity path traversal vulnerability in Plone Plone, published on 7 Mar 2017. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Directory traversal vulnerability in Plone CMS 5.x through 5.0.6 and 4.2.x through 4.3.11 allows remote administrators to read arbitrary files via a .. (dot dot) in the path parameter in a getFile action to Plone/++theme++barceloneta/@@plone.resourceeditor.filemanager-actions.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2016-7135?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 4.2 | 4.3.12 |
| `plone` | PyPI | From 5.0 | 5.0.7, 4.3.12 |
| `plone` | PyPI | From 5.0 | 5.0.7 |
| `Plone` | PyPI | From 4.2 | 4.3.12 |
| `Plone` | PyPI | From 5.0 | 5.0.7 |

Products: Plone Plone.

## How do I fix CVE-2016-7135?

Upgrade plone to a fixed version for your release line: 4.3.12 or 5.0.7.

## Is CVE-2016-7135 being exploited?

There is no known exploitation of CVE-2016-7135 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7135 and fix it if it is affected.

What it is: CVE-2016-7135 is a medium-severity path traversal vulnerability in Plone Plone, published on 7 Mar 2017. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7135 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 4.2; fixed in 4.3.12
- plone (PyPI): affected from 5.0; fixed in 5.0.7, 4.3.12
- plone (PyPI): affected from 5.0; fixed in 5.0.7
- Plone (PyPI): affected from 4.2; fixed in 4.3.12
- Plone (PyPI): affected from 5.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7135/ (Markdown: https://insights.sbomify.com/CVE-2016-7135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7135
- OSV: https://osv.dev/vulnerability/CVE-2016-7135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7135/
Summaries are generated and may contain mistakes; the official description above is the record.
