CVE-2016-7136 Plone XSS
Remote attackers can execute arbitrary scripts in user browsers via crafted GET requests in Plone CMS, requiring an upgrade to mitigate.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7136?
CVE-2016-7136 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
z3c.form in Plone CMS 5.x through 5.0.6 and 4.x through 4.3.11 allows remote attackers to conduct cross-site scripting (XSS) attacks via a crafted GET request.
Weakness: CWE-79
Which versions are affected by CVE-2016-7136?
5 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 4.0.0 to 4.3.11 | None |
plone PyPI | From 5.0 | 5.0.7, 4.3.12 |
plone PyPI | From 5.0.0 to 5.0.6 | None |
Plone PyPI | From 4.0.0 to 4.3.11 | None |
Plone PyPI | From 5.0.0 to 5.0.6 | None |
Products include Plone Plone.
How do I fix CVE-2016-7136?
Upgrade plone to a fixed version for your release line: 5.0.7 or 4.3.12.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-7136 being exploited?
There is no known exploitation of CVE-2016-7136 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-22jm-p2vv-j2hc, PYSEC-2017-59.