CVE-2016-7137 Plone Open Redirect Vulnerability
Remote attackers can redirect users to arbitrary sites via specific parameters, facilitating phishing attacks in Plone CMS.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7137?
CVE-2016-7137 is a medium-severity vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple open redirect vulnerabilities in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allow remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the referer parameter to (1) %2b%2bgroupdashboard%2b%2bplone.dashboard1%2bgroup/%2b/portlets.Actions or (2) folder/%2b%2bcontextportlets%2b%2bplone.footerportlets/%2b /portlets.Actions or the (3) came_from parameter to /login_form.
Weakness: CWE-601
Which versions are affected by CVE-2016-7137?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3 to 3.3.6 | None |
plone PyPI | From 4.0 to 4.3.11 | None |
plone PyPI | From 5.0 | 5.0.7, 4.3.12, 4.0a1 |
plone PyPI | From 5.0 to 5.0.6 | None |
Plone PyPI | From 3.3 to 3.3.6 | None |
Plone PyPI | From 4.0 to 4.3.11 | None |
1 more packages
Plone PyPI | From 5.0 to 5.0.6 | None |
Products include Plone Plone.
How do I fix CVE-2016-7137?
Upgrade plone to a fixed version for your release line: 5.0.7, 4.3.12 or 4.0a1.
Is CVE-2016-7137 being exploited?
There is no known exploitation of CVE-2016-7137 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-69vh-662j-v988, PYSEC-2017-60.