# CVE-2016-7137: Plone Open Redirect Vulnerability

> Remote attackers can redirect users to arbitrary sites via specific parameters, facilitating phishing attacks in Plone CMS.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 7 Mar 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-69vh-662j-v988, PYSEC-2017-60

## What is CVE-2016-7137?

CVE-2016-7137 is a medium-severity vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Multiple open redirect vulnerabilities in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allow remote attackers to redirect users to arbitrary web sites and conduct phishing attacks via a URL in the referer parameter to (1) %2b%2bgroupdashboard%2b%2bplone.dashboard1%2bgroup/%2b/portlets.Actions or (2) folder/%2b%2bcontextportlets%2b%2bplone.footerportlets/%2b /portlets.Actions or the (3) came_from parameter to /login_form.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2016-7137?

7 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | From 3.3 to 3.3.6 | None |
| `plone` | PyPI | From 4.0 to 4.3.11 | None |
| `plone` | PyPI | From 5.0 | 5.0.7, 4.3.12, 4.0a1 |
| `plone` | PyPI | From 5.0 to 5.0.6 | None |
| `Plone` | PyPI | From 3.3 to 3.3.6 | None |
| `Plone` | PyPI | From 4.0 to 4.3.11 | None |
| `Plone` | PyPI | From 5.0 to 5.0.6 | None |

Products: Plone Plone.

## How do I fix CVE-2016-7137?

Upgrade plone to a fixed version for your release line: 5.0.7, 4.3.12 or 4.0a1.

## Is CVE-2016-7137 being exploited?

There is no known exploitation of CVE-2016-7137 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7137 and fix it if it is affected.

What it is: CVE-2016-7137 is a medium-severity vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-7137 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected from 3.3 up to 3.3.6; no fix listed
- plone (PyPI): affected from 4.0 up to 4.3.11; no fix listed
- plone (PyPI): affected from 5.0; fixed in 5.0.7, 4.3.12, 4.0a1
- plone (PyPI): affected from 5.0 up to 5.0.6; no fix listed
- Plone (PyPI): affected from 3.3 up to 3.3.6; no fix listed
- Plone (PyPI): affected from 4.0 up to 4.3.11; no fix listed
- Plone (PyPI): affected from 5.0 up to 5.0.6; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7137/ (Markdown: https://insights.sbomify.com/CVE-2016-7137/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7137
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7137
- OSV: https://osv.dev/vulnerability/CVE-2016-7137

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7137/
Summaries are generated and may contain mistakes; the official description above is the record.
