CVE-2016-7138 Plone XSS
Remote attackers can inject arbitrary web script or HTML via crafted URLs in Plone CMS, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7138?
CVE-2016-7138 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.
Weakness: CWE-79
Which versions are affected by CVE-2016-7138?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3.0 to 3.3.6 | None |
plone PyPI | From 4.0.0 to 4.3.11 | None |
plone PyPI | From 5.0 | 5.0.7, 4.3.12, 4.0a1 |
plone PyPI | From 5.0.0 to 5.0.6 | None |
Plone PyPI | From 3.3.0 to 3.3.6 | None |
Plone PyPI | From 4.0.0 to 4.3.11 | None |
1 more packages
Plone PyPI | From 5.0.0 to 5.0.6 | None |
Products include Plone Plone.
How do I fix CVE-2016-7138?
Upgrade plone to a fixed version for your release line: 5.0.7, 4.3.12 or 4.0a1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-7138 being exploited?
There is no known exploitation of CVE-2016-7138 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-v3hp-f8qr-cf3p, PYSEC-2017-61.