{"answers":{"affected":"7 open source packages ship an affected version, including plone and Plone. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7138 in the wild and no public exploit code.","fix":"Upgrade plone to a fixed version for your release line: 5.0.7, 4.3.12 or 4.0a1.","what":"CVE-2016-7138 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-7138 and fix it if it is affected.\n\nWhat it is: CVE-2016-7138 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-7138 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- plone (PyPI): affected from 3.3.0 up to 3.3.6; no fix listed\n- plone (PyPI): affected from 4.0.0 up to 4.3.11; no fix listed\n- plone (PyPI): affected from 5.0; fixed in 5.0.7, 4.3.12, 4.0a1\n- plone (PyPI): affected from 5.0.0 up to 5.0.6; no fix listed\n- Plone (PyPI): affected from 3.3.0 up to 3.3.6; no fix listed\n- Plone (PyPI): affected from 4.0.0 up to 4.3.11; no fix listed\n- Plone (PyPI): affected from 5.0.0 up to 5.0.6; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7138/ (Markdown: https://insights.sbomify.com/CVE-2016-7138/index.md)","id":"CVE-2016-7138","markdown":"https://insights.sbomify.com/CVE-2016-7138/index.md","name":"CVE-2016-7138","record":{"aliases":["GHSA-v3hp-f8qr-cf3p","PYSEC-2017-61"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Plone CMS","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML via crafted URLs in Plone CMS, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"plone","vendor":"plone"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in the URL checking infrastructure in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via a crafted URL.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Plone XSS","id":"CVE-2016-7138","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"plone:plone","products":["plone:plone"],"type":"xss","year":"2016"},"n_packages":7,"n_references":7,"next":{"headline":"Plone Cross-site Scripting (XSS) vulnerability","id":"CVE-2016-7139"},"packages":[{"ecosystem":"PyPI","fixed":[],"introduced":["3.3.0"],"last_affected":["3.3.6"],"package":"Plone","purl":null,"source":"GHSA-v3hp-f8qr-cf3p"},{"ecosystem":"PyPI","fixed":[],"introduced":["4.0.0"],"last_affected":["4.3.11"],"package":"Plone","purl":null,"source":"GHSA-v3hp-f8qr-cf3p"},{"ecosystem":"PyPI","fixed":[],"introduced":["5.0.0"],"last_affected":["5.0.6"],"package":"Plone","purl":null,"source":"GHSA-v3hp-f8qr-cf3p"},{"ecosystem":"PyPI","fixed":[],"introduced":["3.3.0"],"last_affected":["3.3.6"],"package":"plone","purl":"pkg:pypi/plone","source":"GHSA-v3hp-f8qr-cf3p"},{"ecosystem":"PyPI","fixed":[],"introduced":["4.0.0"],"last_affected":["4.3.11"],"package":"plone","purl":"pkg:pypi/plone","source":"GHSA-v3hp-f8qr-cf3p"},{"ecosystem":"PyPI","fixed":["5.0.7","4.3.12","4.0a1"],"introduced":["5.0","4.0","3.3"],"last_affected":[],"package":"plone","purl":"pkg:pypi/plone","source":"PYSEC-2017-61"},{"ecosystem":"PyPI","fixed":[],"introduced":["5.0.0"],"last_affected":["5.0.6"],"package":"plone","purl":"pkg:pypi/plone","source":"GHSA-v3hp-f8qr-cf3p"}],"prev":{"headline":"Plone Open Redirect Vulnerability","id":"CVE-2016-7137"},"products":["n/a"],"published":"2017-03-07","related":[{"cvss_score":9.9,"headline":"Incorrect Permission Assignment for Critical Resource in Plone","id":"CVE-2021-33509","kev_date_added":null,"published":"2021-05-21"},{"cvss_score":9.8,"headline":"Hardcoded credentials in n/a","id":"CVE-2020-35190","kev_date_added":null,"published":"2020-12-17"},{"cvss_score":9.8,"headline":"Plone Unauthenticated Write Vulnerability","id":"CVE-2020-7941","kev_date_added":null,"published":"2020-01-23"},{"cvss_score":9.3,"headline":"Zope Command Execution Vulnerability","id":"CVE-2011-3587","kev_date_added":null,"published":"2011-10-10"},{"cvss_score":8.8,"headline":"Server-Side Request Forgery in Plone CMS","id":"CVE-2021-33926","kev_date_added":null,"published":"2023-02-17"},{"cvss_score":8.8,"headline":"Improper Restriction of XML External Entity Reference in Plone","id":"CVE-2020-28734","kev_date_added":null,"published":"2020-12-30"},{"cvss_score":8.8,"headline":"SSRF attacks via tracebacks in Plone","id":"CVE-2020-28735","kev_date_added":null,"published":"2020-12-30"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML via crafted URLs in Plone CMS, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2016-7138/"}