CVE-2016-7139 Plone Cross-site Scripting (XSS) vulnerability
Remote attackers can inject arbitrary web script or HTML into Plone CMS pages, potentially compromising user sessions or site integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7139?
CVE-2016-7139 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in an unspecified page template in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allows remote attackers to inject arbitrary web script or HTML via unknown vectors.
Weakness: CWE-79
Which versions are affected by CVE-2016-7139?
7 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3 to 3.3.6 | None |
plone PyPI | From 4.0a1 | 4.3.12 |
plone PyPI | From 5.0 | 5.0.7, 4.3.12, 4.0a1 |
plone PyPI | From 5.0 | 5.0.6 |
Plone PyPI | From 3.3 to 3.3.6 | None |
Plone PyPI | From 4.0a1 | 4.3.12 |
1 more packages
Plone PyPI | From 5.0 | 5.0.6 |
Products include Plone Plone.
How do I fix CVE-2016-7139?
Upgrade plone to a fixed version for your release line: 4.3.12, 5.0.7, 4.0a1 or 5.0.6.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-7139 being exploited?
There is no known exploitation of CVE-2016-7139 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-pp4c-2692-7f37, PYSEC-2017-62.