CVE-2016-7140 Plone vulnerable to Cross-site Scripting
Remote attackers can inject arbitrary web script or HTML into the Zope2 ZMI page in Plone CMS, potentially compromising user sessions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7140?
CVE-2016-7140 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 7 Mar 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Multiple cross-site scripting (XSS) vulnerabilities in the ZMI page in Zope2 in Plone CMS 5.x through 5.0.6, 4.x through 4.3.11, and 3.3.x through 3.3.6 allow remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Weakness: CWE-79
Which versions are affected by CVE-2016-7140?
5 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | From 3.3a1 | 4.3.12 |
plone PyPI | From 5.0 | 5.0.7, 4.3.12, 4.0a1 |
plone PyPI | From 5.0a1 | 5.0.7 |
Plone PyPI | From 3.3a1 | 4.3.12 |
Plone PyPI | From 5.0a1 | 5.0.7 |
Products include Plone Plone.
How do I fix CVE-2016-7140?
Upgrade plone to a fixed version for your release line: 4.3.12, 5.0.7 or 4.0a1.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-7140 being exploited?
There is no known exploitation of CVE-2016-7140 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-chvw-gjxf-f8mc, PYSEC-2017-63.