# CVE-2016-7146: MoinMoin Cross-site Scripting (XSS) vulnerability

> Remote attackers can execute arbitrary JavaScript via crafted URLs in MoinMoin Wiki, potentially compromising user sessions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Nov 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-fj26-q4vh-85f6, PYSEC-2016-30, UBUNTU-CVE-2016-7146

## What is CVE-2016-7146?

CVE-2016-7146 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

MoinMoin 1.9.8 allows remote attackers to conduct "JavaScript injection" attacks by using the "page creation or crafted URL" approach, related to a "Cross Site Scripting (XSS)" issue affecting the action=fckdialog&dialog=attachment (via page name) component.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-7146?

3 open source packages ship an affected version, including moin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `moin` | PyPI | All versions | 1.9.9 |
| `moin` | PyPI | From 1.9.8 | 1.9.9 |
| `moin` | PyPI | From 1.9.8 | 1.9.9 |

Products: Moinmo Moinmoin.

## How do I fix CVE-2016-7146?

Upgrade moin to 1.9.9 or later.

## Is CVE-2016-7146 being exploited?

There is no known exploitation of CVE-2016-7146 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-15275](https://insights.sbomify.com/CVE-2020-15275/): malicious SVG attachment causing stored XSS vulnerability in MoinMoin (high 8.7)
- [CVE-2009-4762](https://insights.sbomify.com/CVE-2009-4762/): MoinMoin Improper Access Control vulnerability (high 7.5)
- [CVE-2010-0669](https://insights.sbomify.com/CVE-2010-0669/): MoinMoin improper sanitizes user profiles (high 7.5)
- [CVE-2010-0717](https://insights.sbomify.com/CVE-2010-0717/): MoinMoin has improper default configuration (high 7.5)
- [CVE-2010-0668](https://insights.sbomify.com/CVE-2010-0668/): MoinMoin has multiple vulnerabilities related to superuser list, xmlrpc and OpenID configuration (medium 6.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7146 and fix it if it is affected.

What it is: CVE-2016-7146 is a medium-severity cross-site scripting vulnerability in n/a, published on 10 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-7146 in the wild and no public exploit code.

Affected packages and fixed versions:
- moin (PyPI): affected all versions; fixed in 1.9.9
- moin (PyPI): affected from 1.9.8; fixed in 1.9.9
- moin (PyPI): affected from 1.9.8; fixed in 1.9.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7146/ (Markdown: https://insights.sbomify.com/CVE-2016-7146/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7146
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7146
- OSV: https://osv.dev/vulnerability/CVE-2016-7146

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7146/
Summaries are generated and may contain mistakes; the official description above is the record.
