CVE-2016-7147 Plone XSS in Zope ZMI
Remote attackers can inject arbitrary web script or HTML into the Plone search feature, potentially compromising user sessions or site integrity.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2016-7147?
CVE-2016-7147 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 4 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Cross-site scripting (XSS) vulnerability in the manage_findResult component in the search feature in Zope ZMI in Plone before 4.3.12 and 5.x before 5.0.7 allows remote attackers to inject arbitrary web script or HTML via vectors involving double quotes, as demonstrated by the obj_ids:tokens parameter. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-7140.
Weakness: CWE-79
Which versions are affected by CVE-2016-7147?
5 open source packages ship an affected version, including plone and Plone. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
plone PyPI | All versions | 4.3.12, 5.0.7 |
plone PyPI | From 4.0 | 4.3.12 |
plone PyPI | From 5.0 | 5.0.7 |
Plone PyPI | From 4.0 | 4.3.12 |
Plone PyPI | From 5.0 | 5.0.7 |
Products include Plone Plone.
How do I fix CVE-2016-7147?
Upgrade plone to a fixed version for your release line: 4.3.12 or 5.0.7.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2016-7147 being exploited?
There is no known exploitation of CVE-2016-7147 in the wild and no public exploit code.
Other vulnerabilities in Plone Plone
Sources
Also known as GHSA-84jm-cpc5-c7g7, PYSEC-2017-64, UBUNTU-CVE-2016-7147.