# CVE-2016-7147: Plone XSS in Zope ZMI

> Remote attackers can inject arbitrary web script or HTML into the Plone search feature, potentially compromising user sessions or site integrity.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 4 Feb 2017
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-84jm-cpc5-c7g7, PYSEC-2017-64, UBUNTU-CVE-2016-7147

## What is CVE-2016-7147?

CVE-2016-7147 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 4 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in the manage_findResult component in the search feature in Zope ZMI in Plone before 4.3.12 and 5.x before 5.0.7 allows remote attackers to inject arbitrary web script or HTML via vectors involving double quotes, as demonstrated by the obj_ids:tokens parameter. NOTE: this vulnerability exists because of an incomplete fix for CVE-2016-7140.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2016-7147?

5 open source packages ship an affected version, including plone and Plone. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `plone` | PyPI | All versions | 4.3.12, 5.0.7 |
| `plone` | PyPI | From 4.0 | 4.3.12 |
| `plone` | PyPI | From 5.0 | 5.0.7 |
| `Plone` | PyPI | From 4.0 | 4.3.12 |
| `Plone` | PyPI | From 5.0 | 5.0.7 |

Products: Plone Plone.

## How do I fix CVE-2016-7147?

Upgrade plone to a fixed version for your release line: 4.3.12 or 5.0.7.

## Is CVE-2016-7147 being exploited?

There is no known exploitation of CVE-2016-7147 in the wild and no public exploit code.

## Other vulnerabilities in Plone Plone

- [CVE-2021-33509](https://insights.sbomify.com/CVE-2021-33509/): Incorrect Permission Assignment for Critical Resource in Plone (critical 9.9)
- [CVE-2020-35190](https://insights.sbomify.com/CVE-2020-35190/): Hardcoded credentials in n/a (critical 9.8)
- [CVE-2020-7941](https://insights.sbomify.com/CVE-2020-7941/): Plone Unauthenticated Write Vulnerability (critical 9.8)
- [CVE-2011-3587](https://insights.sbomify.com/CVE-2011-3587/): Zope Command Execution Vulnerability (critical 9.3)
- [CVE-2021-33926](https://insights.sbomify.com/CVE-2021-33926/): Server-Side Request Forgery in Plone CMS (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7147 and fix it if it is affected.

What it is: CVE-2016-7147 is a medium-severity cross-site scripting vulnerability in Plone Plone, published on 4 Feb 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-7147 in the wild and no public exploit code.

Affected packages and fixed versions:
- plone (PyPI): affected all versions; fixed in 4.3.12, 5.0.7
- plone (PyPI): affected from 4.0; fixed in 4.3.12
- plone (PyPI): affected from 5.0; fixed in 5.0.7
- Plone (PyPI): affected from 4.0; fixed in 4.3.12
- Plone (PyPI): affected from 5.0; fixed in 5.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7147/ (Markdown: https://insights.sbomify.com/CVE-2016-7147/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7147
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7147
- OSV: https://osv.dev/vulnerability/CVE-2016-7147

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7147/
Summaries are generated and may contain mistakes; the official description above is the record.
