CVE-2016-7191 Authentication Bypass in passport-azure-ad
Attackers can bypass authentication in the Azure AD Passport library by exploiting ignored issuer validation settings, requiring an upgrade to secure versions.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-7191?
CVE-2016-7191 is a high-severity authentication bypass vulnerability in n/a, published on 28 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The Microsoft Azure Active Directory Passport (aka Passport-Azure-AD) library 1.x before 1.4.6 and 2.x before 2.0.1 for Node.js does not recognize the validateIssuer setting, which allows remote attackers to bypass authentication via a crafted token.
Weakness: CWE-287
Which versions are affected by CVE-2016-7191?
4 open source packages ship an affected version, including passport-azure-ad. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
passport-azure-ad npm | From 1.0.0 | 1.4.6 |
passport-azure-ad npm | From 1.0.0 | 1.4.6 |
passport-azure-ad npm | From 2.0.0 | 2.0.1 |
passport-azure-ad npm | From 2.0.0 | 2.0.1 |
Products include Microsoft Azure Active Directory Passport.
How do I fix CVE-2016-7191?
Upgrade passport-azure-ad to a fixed version for your release line: 1.4.6 or 2.0.1.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2016-7191 being exploited?
There is no known exploitation of CVE-2016-7191 in the wild and no public exploit code.
Sources
Also known as GHSA-73jp-3c67-hjfv.