{"answers":{"affected":"4 open source packages ship an affected version, including passport-azure-ad. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7191 in the wild and no public exploit code.","fix":"Upgrade passport-azure-ad to a fixed version for your release line: 1.4.6 or 2.0.1.","what":"CVE-2016-7191 is a high-severity authentication bypass vulnerability in n/a, published on 28 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7191 and fix it if it is affected.\n\nWhat it is: CVE-2016-7191 is a high-severity authentication bypass vulnerability in n/a, published on 28 Sep 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7191 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- passport-azure-ad (npm): affected from 1.0.0; fixed in 1.4.6\n- passport-azure-ad (npm): affected from 1.0.0; fixed in 1.4.6\n- passport-azure-ad (npm): affected from 2.0.0; fixed in 2.0.1\n- passport-azure-ad (npm): affected from 2.0.0; fixed in 2.0.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7191/ (Markdown: https://insights.sbomify.com/CVE-2016-7191/index.md)","id":"CVE-2016-7191","markdown":"https://insights.sbomify.com/CVE-2016-7191/index.md","name":"CVE-2016-7191","record":{"aliases":["GHSA-73jp-3c67-hjfv"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js Azure AD library","requires_auth":"none","summary":"Attackers can bypass authentication in the Azure AD Passport library by exploiting ignored issuer validation settings, requiring an upgrade to secure versions.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microsoft","cpe":[{"product":"azure_active_directory_passport","vendor":"microsoft"}],"cvss":{"score":8.1,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"}],"description":"The Microsoft Azure Active Directory Passport (aka Passport-Azure-AD) library 1.x before 1.4.6 and 2.x before 2.0.1 for Node.js does not recognize the validateIssuer setting, which allows remote attackers to bypass authentication via a crafted token.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Authentication Bypass in passport-azure-ad","id":"CVE-2016-7191","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"auth_bypass","year":"2016"},"n_packages":4,"n_references":4,"next":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-7192"},"packages":[{"ecosystem":"npm","fixed":["1.4.6"],"introduced":["1.0.0"],"last_affected":[],"package":"passport-azure-ad","purl":null,"source":"GHSA-73jp-3c67-hjfv"},{"ecosystem":"npm","fixed":["1.4.6"],"introduced":["1.0.0"],"last_affected":[],"package":"passport-azure-ad","purl":"pkg:npm/passport-azure-ad","source":"GHSA-73jp-3c67-hjfv"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"passport-azure-ad","purl":null,"source":"GHSA-73jp-3c67-hjfv"},{"ecosystem":"npm","fixed":["2.0.1"],"introduced":["2.0.0"],"last_affected":[],"package":"passport-azure-ad","purl":"pkg:npm/passport-azure-ad","source":"GHSA-73jp-3c67-hjfv"}],"prev":{"headline":"ChakraCore RCE Vulnerability","id":"CVE-2016-7190"},"products":["n/a"],"published":"2016-09-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Attackers can bypass authentication in the Azure AD Passport library by exploiting ignored issuer validation settings, requiring an upgrade to secure versions.","url":"https://insights.sbomify.com/CVE-2016-7191/"}