CVE-2016-7401 Django CSRF Protection Bypass
Attackers can bypass CSRF protection in Django sites using Google Analytics by setting arbitrary cookies, requiring an upgrade to secure the application.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-7401?
CVE-2016-7401 is a high-severity vulnerability in Canonical Ubuntu Linux, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
The cookie parsing code in Django before 1.8.15 and 1.9.x before 1.9.10, when used on a site with Google Analytics, allows remote attackers to bypass an intended CSRF protection mechanism by setting arbitrary cookies.
Weakness: CWE-254
Which versions are affected by CVE-2016-7401?
5 open source packages ship an affected version, including django and Django. It affects 3 products.
| Package | Affected | Fixed in |
|---|---|---|
django PyPI | All versions | 1.8.15, 1.9.10 |
django PyPI | All versions | 1.8.15 |
django PyPI | From 1.9 | 1.9.10 |
Django PyPI | All versions | 1.8.15 |
Django PyPI | From 1.9 | 1.9.10 |
Linux distribution packages (21)
python-django Red Hat:openstack:5::el6 | All versions | 0:1.6.11-6.el6ost |
python-django-bash-completion Red Hat:openstack:5::el6 | All versions | 0:1.6.11-6.el6ost |
python-django-doc Red Hat:openstack:5::el6 | All versions | 0:1.6.11-6.el6ost |
python-django Red Hat:openstack:5::el7 | All versions | 0:1.6.11-6.el7ost |
python-django-bash-completion Red Hat:openstack:5::el7 | All versions | 0:1.6.11-6.el7ost |
python-django-doc Red Hat:openstack:5::el7 | All versions | 0:1.6.11-6.el7ost |
python-django Red Hat:openstack:6::el7 | All versions | 0:1.6.11-6.el7ost |
python-django-bash-completion Red Hat:openstack:6::el7 | All versions | 0:1.6.11-6.el7ost |
python-django-doc Red Hat:openstack:6::el7 | All versions | 0:1.6.11-6.el7ost |
python-django Red Hat:openstack:7::el7 | All versions | 0:1.8.15-1.el7ost |
python-django-bash-completion Red Hat:openstack:7::el7 | All versions | 0:1.8.15-1.el7ost |
python-django-doc Red Hat:openstack:7::el7 | All versions | 0:1.8.15-1.el7ost |
python-django Red Hat:openstack:8::el7 | All versions | 0:1.8.15-1.el7ost |
python-django-bash-completion Red Hat:openstack:8::el7 | All versions | 0:1.8.15-1.el7ost |
python-django Red Hat:openstack:9::el7 | All versions | 0:1.8.15-1.el7ost |
python-django-bash-completion Red Hat:openstack:9::el7 | All versions | 0:1.8.15-1.el7ost |
ruby3.2-rubygem-http-cookie openSUSE:Tumbleweed | All versions | 1.0.5-1.4 |
rubygem-http-cookie openSUSE:Tumbleweed | All versions | 1.0.5-1.1 |
rubygem-http-cookie openSUSE:Tumbleweed | All versions | 1.0.6-1.1 |
rubygem-http-cookie openSUSE:Tumbleweed | All versions | 1.0.8-1.1 |
rubygem-http-cookie openSUSE:Tumbleweed | All versions | 1.0.8-1.3 |
Products include Canonical Ubuntu Linux, Debian Debian Linux, Djangoproject Django.
How do I fix CVE-2016-7401?
Upgrade django to a fixed version for your release line: 1.8.15 or 1.9.10.
Is CVE-2016-7401 being exploited?
There is no known exploitation of CVE-2016-7401 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as DEBIAN-CVE-2016-7401, DLA-649-1, DSA-3678-1, GHSA-crhm-qpjc-cm64, MGASA-2016-0334, PYSEC-2016-3 and 14 more.