{"answers":{"affected":"2 open source packages ship an affected version, including adodb/adodb-php. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-7405 in the wild and no public exploit code.","fix":"Upgrade adodb/adodb-php to 5.20.7 or later.","what":"CVE-2016-7405 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7405 and fix it if it is affected.\n\nWhat it is: CVE-2016-7405 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7405 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- adodb/adodb-php (Packagist): affected from 5.0; fixed in 5.20.7\n- adodb/adodb-php (Packagist): affected from 5.0; fixed in 5.20.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7405/ (Markdown: https://insights.sbomify.com/CVE-2016-7405/index.md)","id":"CVE-2016-7405","markdown":"https://insights.sbomify.com/CVE-2016-7405/index.md","name":"CVE-2016-7405","record":{"aliases":["DEBIAN-CVE-2016-7405","GHSA-3fj4-q72x-x2g9","UBUNTU-CVE-2016-7405"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP database library","requires_auth":"none","summary":"Remote attackers can execute arbitrary SQL commands via incorrect quoting in the ADOdb PHP library's PDO driver.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"adodb","vendor":"adodb_project"},{"product":"fedora","vendor":"fedoraproject"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ADOdb Library SQL Injection","id":"CVE-2016-7405","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"sql_injection","year":"2016"},"n_packages":2,"n_references":8,"next":{"headline":"Code injection in n/a","id":"CVE-2016-7406"},"packages":[{"ecosystem":"Packagist","fixed":["5.20.7"],"introduced":["5.0"],"last_affected":[],"package":"adodb/adodb-php","purl":null,"source":"GHSA-3fj4-q72x-x2g9"},{"ecosystem":"Packagist","fixed":["5.20.7"],"introduced":["5.0"],"last_affected":[],"package":"adodb/adodb-php","purl":"pkg:composer/adodb/adodb-php","source":"GHSA-3fj4-q72x-x2g9"}],"prev":{"headline":"Openstack Magnum Unsafe Credential Handling","id":"CVE-2016-7404"},"products":["n/a"],"published":"2016-10-03","related":[{"cvss_score":9.1,"headline":"Authentication Bypass by Primary Weakness in adodb/adodb","id":"CVE-2021-3850","kev_date_added":null,"published":"2022-01-25"},{"cvss_score":6.1,"headline":"ADOdb Cross-site scripting vulnerability in old test script","id":"CVE-2016-4855","kev_date_added":null,"published":"2017-05-12"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary SQL commands via incorrect quoting in the ADOdb PHP library's PDO driver.","url":"https://insights.sbomify.com/CVE-2016-7405/"}