# CVE-2016-7405: ADOdb Library SQL Injection

> Remote attackers can execute arbitrary SQL commands via incorrect quoting in the ADOdb PHP library's PDO driver.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-7405, GHSA-3fj4-q72x-x2g9, UBUNTU-CVE-2016-7405

## What is CVE-2016-7405?

CVE-2016-7405 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The qstr method in the PDO driver in the ADOdb Library for PHP before 5.x before 5.20.7 might allow remote attackers to conduct SQL injection attacks via vectors related to incorrect quoting.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2016-7405?

2 open source packages ship an affected version, including adodb/adodb-php. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adodb/adodb-php` | Packagist | From 5.0 | 5.20.7 |
| `adodb/adodb-php` | Packagist | From 5.0 | 5.20.7 |

Products: Adodb Project Adodb, Fedoraproject Fedora.

## How do I fix CVE-2016-7405?

Upgrade adodb/adodb-php to 5.20.7 or later.

## Is CVE-2016-7405 being exploited?

There is no known exploitation of CVE-2016-7405 in the wild and no public exploit code.

## Other vulnerabilities in Fedoraproject Fedora

- [CVE-2021-3850](https://insights.sbomify.com/CVE-2021-3850/): Authentication Bypass by Primary Weakness in adodb/adodb (critical 9.1)
- [CVE-2016-4855](https://insights.sbomify.com/CVE-2016-4855/): ADOdb Cross-site scripting vulnerability in old test script (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7405 and fix it if it is affected.

What it is: CVE-2016-7405 is a critical SQL injection vulnerability in Fedoraproject Fedora, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7405 in the wild and no public exploit code.

Affected packages and fixed versions:
- adodb/adodb-php (Packagist): affected from 5.0; fixed in 5.20.7
- adodb/adodb-php (Packagist): affected from 5.0; fixed in 5.20.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7405/ (Markdown: https://insights.sbomify.com/CVE-2016-7405/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7405
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7405
- OSV: https://osv.dev/vulnerability/CVE-2016-7405

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7405/
Summaries are generated and may contain mistakes; the official description above is the record.
