# CVE-2016-7570: Drupal Users without "Administer comments" can set comment visibility on nodes they can edit

> Authenticated users can modify comment visibility on arbitrary nodes due to missing permission checks in Drupal 8.

- **Severity:** Medium 4.3 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-6g9h-6v79-w4pc

## What is CVE-2016-7570?

CVE-2016-7570 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 3 Oct 2016. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Drupal 8.x before 8.1.10 does not properly check for "Administer comments" permission, which allows remote authenticated users to set the visibility of comments for arbitrary nodes by leveraging rights to edit those nodes.

Weakness: CWE-264

## Which versions are affected by CVE-2016-7570?

4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `drupal/core` | Packagist | From 8.0.0 | 8.1.10 |
| `drupal/core` | Packagist | From 8.0.0 | 8.1.10 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.1.10 |
| `drupal/drupal` | Packagist | From 8.0.0 | 8.1.10 |

Products: Drupal Drupal.

## How do I fix CVE-2016-7570?

Upgrade drupal/core to 8.1.10 or later.

## Is CVE-2016-7570 being exploited?

There is no known exploitation of CVE-2016-7570 in the wild and no public exploit code.

## Other vulnerabilities in Drupal Drupal

- [CVE-2026-9082](https://insights.sbomify.com/CVE-2026-9082/): Drupal Core SQL Injection (critical 9.8, exploited in the wild)
- [CVE-2020-13671](https://insights.sbomify.com/CVE-2020-13671/): Drupal core Un-restricted Upload of File (high 8.8, exploited in the wild)
- [CVE-2019-6340](https://insights.sbomify.com/CVE-2019-6340/): Drupal Core Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2009-3352](https://insights.sbomify.com/CVE-2009-3352/): Other in n/a (critical 10.0)
- [CVE-2024-55636](https://insights.sbomify.com/CVE-2024-55636/): Drupal core - Less critical - Gadget chain - SA-CORE-2024-006 (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7570 and fix it if it is affected.

What it is: CVE-2016-7570 is a medium-severity missing authorization vulnerability in Drupal Drupal, published on 3 Oct 2016. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7570 in the wild and no public exploit code.

Affected packages and fixed versions:
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.1.10
- drupal/core (Packagist): affected from 8.0.0; fixed in 8.1.10
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.1.10
- drupal/drupal (Packagist): affected from 8.0.0; fixed in 8.1.10

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7570/ (Markdown: https://insights.sbomify.com/CVE-2016-7570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7570
- OSV: https://osv.dev/vulnerability/CVE-2016-7570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7570/
Summaries are generated and may contain mistakes; the official description above is the record.
