{"answers":{"affected":"4 open source packages ship an affected version, including drupal/core and drupal/drupal. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7571 in the wild and no public exploit code.","fix":"Upgrade drupal/core to 8.1.10 or later.","what":"CVE-2016-7571 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-7571 and fix it if it is affected.\n\nWhat it is: CVE-2016-7571 is a medium-severity cross-site scripting vulnerability in Drupal Drupal, published on 3 Oct 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-7571 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- drupal/core (Packagist): affected from 8.0; fixed in 8.1.10\n- drupal/core (Packagist): affected from 8.0; fixed in 8.1.10\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.1.10\n- drupal/drupal (Packagist): affected from 8.0; fixed in 8.1.10\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7571/ (Markdown: https://insights.sbomify.com/CVE-2016-7571/index.md)","id":"CVE-2016-7571","markdown":"https://insights.sbomify.com/CVE-2016-7571/index.md","name":"CVE-2016-7571","record":{"aliases":["GHSA-vhg8-x858-7wq6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Drupal CMS","requires_auth":"none","summary":"Remote attackers can inject arbitrary web script or HTML into Drupal 8 via HTTP exception vectors, potentially compromising user sessions.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"drupal","vendor":"drupal"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"Cross-site scripting (XSS) vulnerability in Drupal 8.x before 8.1.10 allows remote attackers to inject arbitrary web script or HTML via vectors involving an HTTP exception.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Drupal Cross-site scripting (XSS) vulnerability","id":"CVE-2016-7571","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"drupal:drupal","products":["drupal:drupal"],"type":"xss","year":"2016"},"n_packages":4,"n_references":3,"next":{"headline":"Drupal Unprivileged access to config export","id":"CVE-2016-7572"},"packages":[{"ecosystem":"Packagist","fixed":["8.1.10"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":null,"source":"GHSA-vhg8-x858-7wq6"},{"ecosystem":"Packagist","fixed":["8.1.10"],"introduced":["8.0"],"last_affected":[],"package":"drupal/core","purl":"pkg:composer/drupal/core","source":"GHSA-vhg8-x858-7wq6"},{"ecosystem":"Packagist","fixed":["8.1.10"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":null,"source":"GHSA-vhg8-x858-7wq6"},{"ecosystem":"Packagist","fixed":["8.1.10"],"introduced":["8.0"],"last_affected":[],"package":"drupal/drupal","purl":"pkg:composer/drupal/drupal","source":"GHSA-vhg8-x858-7wq6"}],"prev":{"headline":"Drupal Users without \"Administer comments\" can set comment visibility on nodes they can edit","id":"CVE-2016-7570"},"products":["n/a"],"published":"2016-10-03","related":[{"cvss_score":9.8,"headline":"Drupal Core SQL Injection","id":"CVE-2026-9082","kev_date_added":"2026-05-22","published":"2026-05-20"},{"cvss_score":8.8,"headline":"Drupal core Un-restricted Upload of File","id":"CVE-2020-13671","kev_date_added":"2022-01-18","published":"2020-11-20"},{"cvss_score":8.1,"headline":"Drupal Core Remote Code Execution","id":"CVE-2019-6340","kev_date_added":"2022-03-25","published":"2019-02-21"},{"cvss_score":10,"headline":"Other in n/a","id":"CVE-2009-3352","kev_date_added":null,"published":"2009-09-24"},{"cvss_score":9.8,"headline":"Drupal core - Less critical - Gadget chain - SA-CORE-2024-006","id":"CVE-2024-55636","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-007","id":"CVE-2024-55637","kev_date_added":null,"published":"2024-12-09"},{"cvss_score":9.8,"headline":"Drupal core - Moderately critical - Gadget chain - SA-CORE-2024-008","id":"CVE-2024-55638","kev_date_added":null,"published":"2024-12-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary web script or HTML into Drupal 8 via HTTP exception vectors, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2016-7571/"}