{"answers":{"affected":"It affects 7 products.","exploited":"There is no known exploitation of CVE-2016-7797 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-7797 is a high-severity denial of service vulnerability in Opensuse Leap, published on 24 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7797 and fix it if it is affected.\n\nWhat it is: CVE-2016-7797 is a high-severity denial of service vulnerability in Opensuse Leap, published on 24 Mar 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7797 in the wild and no public exploit code.\n\nAffected product: Opensuse Leap. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7797/ (Markdown: https://insights.sbomify.com/CVE-2016-7797/index.md)","id":"CVE-2016-7797","markdown":"https://insights.sbomify.com/CVE-2016-7797/index.md","name":"CVE-2016-7797","record":{"aliases":["DEBIAN-CVE-2016-7797","GHSA-gp6f-9wm3-5hr4","RHSA-2016:2578","UBUNTU-CVE-2016-7797"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Pacemaker cluster manager","requires_auth":"none","summary":"Remote attackers can cause denial of service by disconnecting nodes via unauthenticated connections when Pacemaker remote is enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pacemaker","vendor":"clusterlabs"},{"product":"leap","vendor":"opensuse"},{"product":"leap","vendor":"opensuse_project"},{"product":"enterprise_linux_high_availability","vendor":"redhat"},{"product":"enterprise_linux_resilient_storage","vendor":"redhat"},{"product":"linux_enterprise_high_availability","vendor":"suse"},{"product":"linux_enterprise_software_development_kit","vendor":"suse"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-254","name":null}],"description":"Pacemaker before 1.1.15, when using pacemaker remote, might allow remote attackers to cause a denial of service (node disconnection) via an unauthenticated connection.","ecosystems":["Red Hat:enterprise_linux:7::server"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2016-7797","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"opensuse:leap","products":["opensuse:leap","suse:linux_enterprise_software_development_kit"],"type":"denial_of_service","year":"2016"},"n_packages":10,"n_references":8,"next":{"headline":"OpenSSL gem for Ruby using inadequate encryption strength","id":"CVE-2016-7798"},"packages":[{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker","purl":"pkg:rpm/redhat/pacemaker","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-cli","purl":"pkg:rpm/redhat/pacemaker-cli","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-cluster-libs","purl":"pkg:rpm/redhat/pacemaker-cluster-libs","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-cts","purl":"pkg:rpm/redhat/pacemaker-cts","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-debuginfo","purl":"pkg:rpm/redhat/pacemaker-debuginfo","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-doc","purl":"pkg:rpm/redhat/pacemaker-doc","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-libs","purl":"pkg:rpm/redhat/pacemaker-libs","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-libs-devel","purl":"pkg:rpm/redhat/pacemaker-libs-devel","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-nagios-plugins-metadata","purl":"pkg:rpm/redhat/pacemaker-nagios-plugins-metadata","source":"RHSA-2016:2578"},{"ecosystem":"Red Hat:enterprise_linux:7::server","fixed":["0:1.1.15-11.el7"],"introduced":["0"],"last_affected":[],"package":"pacemaker-remote","purl":"pkg:rpm/redhat/pacemaker-remote","source":"RHSA-2016:2578"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-7796"},"products":["n/a"],"published":"2017-03-24","related":[{"cvss_score":8.8,"headline":"Missing authorization in pacemaker","id":"CVE-2016-7035","kev_date_added":null,"published":"2018-09-10"},{"cvss_score":7.5,"headline":"Privilege escalation in n/a","id":"CVE-2015-1867","kev_date_added":null,"published":"2015-08-12"},{"cvss_score":7.2,"headline":"Auth bypass in pacemaker","id":"CVE-2020-25654","kev_date_added":null,"published":"2020-11-24"},{"cvss_score":5.5,"headline":"Path traversal in n/a","id":"CVE-2011-5271","kev_date_added":null,"published":"2019-11-12"},{"cvss_score":4.3,"headline":"Denial of service in n/a","id":"CVE-2013-0281","kev_date_added":null,"published":"2013-11-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause denial of service by disconnecting nodes via unauthenticated connections when Pacemaker remote is enabled.","url":"https://insights.sbomify.com/CVE-2016-7797/"}