{"answers":{"affected":"2 open source packages ship an affected version, including openssl. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-7798 in the wild and no public exploit code.","fix":"Upgrade openssl to 2.0.0 or later.","what":"CVE-2016-7798 is a high-severity vulnerability in Debian Debian Linux, published on 30 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7798 and fix it if it is affected.\n\nWhat it is: CVE-2016-7798 is a high-severity vulnerability in Debian Debian Linux, published on 30 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7798 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openssl (RubyGems): affected all versions; fixed in 2.0.0\n- openssl (RubyGems): affected all versions; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7798/ (Markdown: https://insights.sbomify.com/CVE-2016-7798/index.md)","id":"CVE-2016-7798","markdown":"https://insights.sbomify.com/CVE-2016-7798/index.md","name":"CVE-2016-7798","record":{"aliases":["DEBIAN-CVE-2016-7798","GHSA-6h88-qjpv-p32m","MGASA-2016-0342","UBUNTU-CVE-2016-7798"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby OpenSSL gem","requires_auth":"none","summary":"The Ruby OpenSSL gem reuses initialization vectors in GCM mode, allowing attackers to bypass encryption protection mechanisms.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"debian_linux","vendor":"debian"},{"product":"openssl","vendor":"ruby-lang"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-326","name":"Inadequate Encryption Strength"}],"description":"The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenSSL gem for Ruby using inadequate encryption strength","id":"CVE-2016-7798","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":"debian:debian_linux","products":["debian:debian_linux"],"type":"weak_cryptography","year":"2016"},"n_packages":2,"n_references":8,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-7799"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":null,"source":"GHSA-6h88-qjpv-p32m"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["0"],"last_affected":[],"package":"openssl","purl":"pkg:gem/openssl","source":"GHSA-6h88-qjpv-p32m"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-7797"},"products":["n/a"],"published":"2017-01-30","related":[{"cvss_score":10,"headline":"ProFTPD Improper Access Control","id":"CVE-2015-3306","kev_date_added":"2026-10-08","published":"2015-05-18"},{"cvss_score":9.9,"headline":"RoundCube Webmail Deserialization of Untrusted Data","id":"CVE-2025-49113","kev_date_added":"2026-02-20","published":"2025-06-02"},{"cvss_score":9.8,"headline":"GNU InetUtils Argument Injection","id":"CVE-2026-24061","kev_date_added":"2026-01-26","published":"2026-01-21"},{"cvss_score":9.8,"headline":"Linux Kernel Improper Check for Unusual or Exceptional Conditions","id":"CVE-2025-39682","kev_date_added":"2026-09-18","published":"2025-09-05"},{"cvss_score":9.8,"headline":"Mozilla Firefox Use-After-Free","id":"CVE-2024-9680","kev_date_added":"2024-10-15","published":"2024-10-09"},{"cvss_score":9.8,"headline":"RARLAB UnRAR Directory Traversal","id":"CVE-2022-30333","kev_date_added":"2022-08-09","published":"2022-05-09"},{"cvss_score":9.8,"headline":"Roundcube Webmail SQL Injection","id":"CVE-2021-44026","kev_date_added":"2023-06-22","published":"2021-11-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"The Ruby OpenSSL gem reuses initialization vectors in GCM mode, allowing attackers to bypass encryption protection mechanisms.","url":"https://insights.sbomify.com/CVE-2016-7798/"}