# CVE-2016-7798: OpenSSL gem for Ruby using inadequate encryption strength

> The Ruby OpenSSL gem reuses initialization vectors in GCM mode, allowing attackers to bypass encryption protection mechanisms.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2017
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-7798, GHSA-6h88-qjpv-p32m, MGASA-2016-0342, UBUNTU-CVE-2016-7798

## What is CVE-2016-7798?

CVE-2016-7798 is a high-severity vulnerability in Debian Debian Linux, published on 30 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The openssl gem for Ruby uses the same initialization vector (IV) in GCM Mode (aes-*-gcm) when the IV is set before the key, which makes it easier for context-dependent attackers to bypass the encryption protection mechanism.

Weakness: CWE-326 (Inadequate Encryption Strength)

## Which versions are affected by CVE-2016-7798?

2 open source packages ship an affected version, including openssl. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openssl` | RubyGems | All versions | 2.0.0 |
| `openssl` | RubyGems | All versions | 2.0.0 |

Products: Debian Debian Linux, Ruby-Lang Openssl.

## How do I fix CVE-2016-7798?

Upgrade openssl to 2.0.0 or later.

## Is CVE-2016-7798 being exploited?

There is no known exploitation of CVE-2016-7798 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7798 and fix it if it is affected.

What it is: CVE-2016-7798 is a high-severity vulnerability in Debian Debian Linux, published on 30 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7798 in the wild and no public exploit code.

Affected packages and fixed versions:
- openssl (RubyGems): affected all versions; fixed in 2.0.0
- openssl (RubyGems): affected all versions; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7798/ (Markdown: https://insights.sbomify.com/CVE-2016-7798/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7798
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7798
- OSV: https://osv.dev/vulnerability/CVE-2016-7798

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7798/
Summaries are generated and may contain mistakes; the official description above is the record.
