{"answers":{"affected":"It affects 4 products.","exploited":"Yes. Attackers have exploited CVE-2016-7855 in the wild since at least 3 Mar 2022.","fix":"Upgrade to a fixed version. US federal agencies must fix it by 24 Mar 2022.","what":"CVE-2016-7855 is a high-severity use after free vulnerability in Adobe Flash Player, published on 1 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-7855 and fix it if it is affected.\n\nWhat it is: CVE-2016-7855 is a high-severity use after free vulnerability in Adobe Flash Player, published on 1 Nov 2016. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: Yes. Attackers have exploited CVE-2016-7855 in the wild since at least 3 Mar 2022.\n\nAffected product: Adobe Flash Player. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7855/ (Markdown: https://insights.sbomify.com/CVE-2016-7855/index.md)","id":"CVE-2016-7855","markdown":"https://insights.sbomify.com/CVE-2016-7855/index.md","name":"CVE-2016-7855","record":{"aliases":["GHSA-fq8g-m89m-mrw9","MGASA-2016-0360","RHSA-2016:2119","SUSE-SU-2016:2662-1","UBUNTU-CVE-2016-7855"],"analysis":{"component_type":"browser","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Adobe Flash Player","requires_auth":"none","summary":"Remote attackers can execute arbitrary code via a use-after-free vulnerability in Adobe Flash Player, requiring users to upgrade to patched versions.","user_interaction":"required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"adobe","cpe":[{"product":"flash_player","vendor":"adobe"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"}],"cvss":{"score":8.8,"severity":"high","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-416","name":"Use After Free"}],"description":"Use-after-free vulnerability in Adobe Flash Player before 23.0.0.205 on Windows and OS X and before 11.2.202.643 on Linux allows remote attackers to execute arbitrary code via unspecified vectors, as exploited in the wild in October 2016.","ecosystems":["Red Hat:rhel_extras:5::client","Red Hat:rhel_extras:5::server","Red Hat:rhel_extras:6","SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Workstation Extension 12 SP1"],"exploits":{"exploitdb":0,"first_seen":"2016-10-26","github_poc":1,"max_poc_stars":0,"metasploit":0,"nuclei":0,"refs":[{"date":"2016-10-26T19:53:29Z","kind":"github_poc","ref":"https://github.com/swagatbora90/CheckFlashPlayerVersion","stars":0,"title":"Check the Browser's FlashPlayer version to check if it is vulnerable to exploit CVE-2016-7855"}],"tier":"exploited"},"has_fix":true,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7855","indexable":true,"kev":{"dateAdded":"2022-03-03","dueDate":"2022-03-24","knownRansomwareCampaignUse":"Unknown","product":"Flash Player","requiredAction":"The impacted product is end-of-life and should be disconnected if still in use.","vendorProject":"Adobe","vulnerabilityName":"Adobe Flash Player Use-After-Free Vulnerability"},"kind":"cve","links":{"ecosystem":null,"product":"adobe:flash_player","products":["adobe:flash_player","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation"],"type":"use_after_free","year":"2016"},"n_packages":5,"n_references":7,"next":{"headline":"Memory corruption in Adobe DNG Converter 9.7 and earlier","id":"CVE-2016-7856"},"packages":[{"ecosystem":"Red Hat:rhel_extras:5::client","fixed":["0:11.2.202.643-1.el5_11"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2016:2119"},{"ecosystem":"Red Hat:rhel_extras:5::server","fixed":["0:11.2.202.643-1.el5_11"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2016:2119"},{"ecosystem":"Red Hat:rhel_extras:6","fixed":["0:11.2.202.643-1.el6_8"],"introduced":["0"],"last_affected":[],"package":"flash-plugin","purl":"pkg:rpm/redhat/flash-plugin","source":"RHSA-2016:2119"},{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["11.2.202.643-146.1"],"introduced":["0"],"last_affected":[],"package":"flash-player","purl":"pkg:rpm/suse/flash-player\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:2662-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP1","fixed":["11.2.202.643-146.1"],"introduced":["0"],"last_affected":[],"package":"flash-player","purl":"pkg:rpm/suse/flash-player\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP1","source":"SUSE-SU-2016:2662-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2016-7854"},"products":["n/a"],"published":"2016-11-01","related":[{"cvss_score":8.8,"headline":"Adobe Flash Player Type Confusion","id":"CVE-2017-11292","kev_date_added":"2022-03-03","published":"2017-10-21"},{"cvss_score":8.8,"headline":"Adobe Flash Player Use-After-Free","id":"CVE-2016-7892","kev_date_added":"2022-03-25","published":"2016-12-15"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Underflow Vulnerablity","id":"CVE-2014-0497","kev_date_added":"2024-09-17","published":"2014-02-05"},{"cvss_score":8.8,"headline":"Adobe Flash Player Incorrect Default Permissions","id":"CVE-2013-0643","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Code Execution","id":"CVE-2013-0648","kev_date_added":"2024-09-17","published":"2013-02-27"},{"cvss_score":8.8,"headline":"Adobe Flash Player Integer Overflow","id":"CVE-2012-5054","kev_date_added":"2022-06-08","published":"2012-09-24"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"open","licence":"CC0 1.0","name":"CISA KEV"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"active","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-10-21","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via a use-after-free vulnerability in Adobe Flash Player, requiring users to upgrade to patched versions.","url":"https://insights.sbomify.com/CVE-2016-7855/"}