{"answers":{"affected":"It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-7947 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-7947 is a critical vulnerability in Fedoraproject Fedora, published on 13 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7947 and fix it if it is affected.\n\nWhat it is: CVE-2016-7947 is a critical vulnerability in Fedoraproject Fedora, published on 13 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7947 in the wild and no public exploit code.\n\nAffected product: Fedoraproject Fedora. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7947/ (Markdown: https://insights.sbomify.com/CVE-2016-7947/index.md)","id":"CVE-2016-7947","markdown":"https://insights.sbomify.com/CVE-2016-7947/index.md","name":"CVE-2016-7947","record":{"aliases":["ALPINE-CVE-2016-7947","DEBIAN-CVE-2016-7947","GHSA-3wrx-wqwj-82vx","UBUNTU-CVE-2016-7947","openSUSE-SU-2024:10923-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"X.org libXrandr library","requires_auth":"none","summary":"Remote X servers can trigger out-of-bounds writes via crafted responses due to integer overflows in libXrandr, potentially allowing code execution.","user_interaction":"not_required","vuln_class":"integer_overflow"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"microfocus","cpe":[{"product":"fedora","vendor":"fedoraproject"},{"product":"libxrandr","vendor":"x.org"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-787","name":"Out-of-bounds Write"},{"id":"CWE-190","name":"Integer Overflow or Wraparound"}],"description":"Multiple integer overflows in X.org libXrandr before 1.5.1 allow remote X servers to trigger out-of-bounds write operations via a crafted response.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Integer overflow in n/a","id":"CVE-2016-7947","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"fedoraproject:fedora","products":["fedoraproject:fedora"],"type":"integer_overflow","year":"2016"},"n_packages":1,"n_references":9,"next":{"headline":"Memory corruption in n/a","id":"CVE-2016-7948"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["1.5.2-1.11"],"introduced":["0"],"last_affected":[],"package":"libXrandr","purl":"pkg:rpm/opensuse/libXrandr\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2024:10923-1"}],"prev":{"headline":"Denial of service in n/a","id":"CVE-2016-7946"},"products":["n/a"],"published":"2016-12-13","related":[{"cvss_score":9.8,"headline":"PHP-CGI OS Command Injection","id":"CVE-2024-4577","kev_date_added":"2024-06-12","published":"2024-06-09"},{"cvss_score":9.8,"headline":"Grafana Authentication Bypass","id":"CVE-2021-39226","kev_date_added":"2022-08-25","published":"2021-10-05"},{"cvss_score":9.8,"headline":"VMware ESXi and Horizon DaaS OpenSLP Heap-Based Buffer Overflow","id":"CVE-2019-5544","kev_date_added":"2021-11-03","published":"2019-12-06"},{"cvss_score":9.6,"headline":"Google Chromium V8 Type Confusion","id":"CVE-2024-4947","kev_date_added":"2024-05-20","published":"2024-05-15"},{"cvss_score":9.6,"headline":"Google Chromium Visuals Use-After-Free","id":"CVE-2024-4671","kev_date_added":"2024-05-13","published":"2024-05-09"},{"cvss_score":9.6,"headline":"Google Chromium Mojo Insufficient Data Validation","id":"CVE-2022-3075","kev_date_added":"2022-09-08","published":"2022-09-26"},{"cvss_score":9.6,"headline":"Google Chromium Indexed DB API Use-After-Free","id":"CVE-2021-30633","kev_date_added":"2021-11-03","published":"2021-10-08"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote X servers can trigger out-of-bounds writes via crafted responses due to integer overflows in libXrandr, potentially allowing code execution.","url":"https://insights.sbomify.com/CVE-2016-7947/"}