{"answers":{"affected":"2 open source packages ship an affected version, including bundler. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-7954 in the wild and no public exploit code.","fix":"Upgrade bundler to 2.0.0 or later.","what":"CVE-2016-7954 is a critical code injection vulnerability in n/a, published on 22 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-7954 and fix it if it is affected.\n\nWhat it is: CVE-2016-7954 is a critical code injection vulnerability in n/a, published on 22 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-7954 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- bundler (RubyGems): affected from 1.0.0; fixed in 2.0.0\n- bundler (RubyGems): affected from 1.0.0; fixed in 2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-7954/ (Markdown: https://insights.sbomify.com/CVE-2016-7954/index.md)","id":"CVE-2016-7954","markdown":"https://insights.sbomify.com/CVE-2016-7954/index.md","name":"CVE-2016-7954","record":{"aliases":["GHSA-jvgm-pfqv-887x","UBUNTU-CVE-2016-7954"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Ruby dependency manager","requires_auth":"none","summary":"Remote attackers can inject arbitrary Ruby code into applications using Bundler by exploiting gem name collisions on secondary sources.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"bundler","vendor":"bundler"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-94","name":"Improper Control of Generation of Code"}],"description":"Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source.  NOTE: this might overlap CVE-2013-0334.","ecosystems":["RubyGems"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Bundler allows attacker to inject arbitrary code via secondary Gem source","id":"CVE-2016-7954","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"RubyGems","product":null,"products":[],"type":"code_injection","year":"2016"},"n_packages":2,"n_references":8,"next":{"headline":"Auth bypass in n/a","id":"CVE-2016-7955"},"packages":[{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["1.0.0"],"last_affected":[],"package":"bundler","purl":null,"source":"GHSA-jvgm-pfqv-887x"},{"ecosystem":"RubyGems","fixed":["2.0.0"],"introduced":["1.0.0"],"last_affected":[],"package":"bundler","purl":"pkg:gem/bundler","source":"GHSA-jvgm-pfqv-887x"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2016-7953"},"products":["n/a"],"published":"2016-12-22","related":[{"cvss_score":8.8,"headline":"Dependency Confusion in Bundler","id":"CVE-2020-36327","kev_date_added":null,"published":"2021-04-29"},{"cvss_score":7.8,"headline":"Insecure path handling in Bundler","id":"CVE-2019-3881","kev_date_added":null,"published":"2020-09-04"},{"cvss_score":6.7,"headline":"Local Code Execution through Argument Injection via dash leading git url parameter in Gemfile","id":"CVE-2021-43809","kev_date_added":null,"published":"2021-12-08"},{"cvss_score":5,"headline":"Bundler may install gems from a different source than expected","id":"CVE-2013-0334","kev_date_added":null,"published":"2014-10-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can inject arbitrary Ruby code into applications using Bundler by exploiting gem name collisions on secondary sources.","url":"https://insights.sbomify.com/CVE-2016-7954/"}