# CVE-2016-7954: Bundler allows attacker to inject arbitrary code via secondary Gem source

> Remote attackers can inject arbitrary Ruby code into applications using Bundler by exploiting gem name collisions on secondary sources.

- **Severity:** Critical 9.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Dec 2016
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-jvgm-pfqv-887x, UBUNTU-CVE-2016-7954

## What is CVE-2016-7954?

CVE-2016-7954 is a critical code injection vulnerability in n/a, published on 22 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Bundler 1.x might allow remote attackers to inject arbitrary Ruby code into an application by leveraging a gem name collision on a secondary source.  NOTE: this might overlap CVE-2013-0334.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2016-7954?

2 open source packages ship an affected version, including bundler. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `bundler` | RubyGems | From 1.0.0 | 2.0.0 |
| `bundler` | RubyGems | From 1.0.0 | 2.0.0 |

Products: Bundler Bundler.

## How do I fix CVE-2016-7954?

Upgrade bundler to 2.0.0 or later.

## Is CVE-2016-7954 being exploited?

There is no known exploitation of CVE-2016-7954 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2020-36327](https://insights.sbomify.com/CVE-2020-36327/): Dependency Confusion in Bundler (high 8.8)
- [CVE-2019-3881](https://insights.sbomify.com/CVE-2019-3881/): Insecure path handling in Bundler (high 7.8)
- [CVE-2021-43809](https://insights.sbomify.com/CVE-2021-43809/): Local Code Execution through Argument Injection via dash leading git url parameter in Gemfile (medium 6.7)
- [CVE-2013-0334](https://insights.sbomify.com/CVE-2013-0334/): Bundler may install gems from a different source than expected (medium 5.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-7954 and fix it if it is affected.

What it is: CVE-2016-7954 is a critical code injection vulnerability in n/a, published on 22 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-7954 in the wild and no public exploit code.

Affected packages and fixed versions:
- bundler (RubyGems): affected from 1.0.0; fixed in 2.0.0
- bundler (RubyGems): affected from 1.0.0; fixed in 2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-7954/ (Markdown: https://insights.sbomify.com/CVE-2016-7954/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-7954
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-7954
- OSV: https://osv.dev/vulnerability/CVE-2016-7954

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-7954/
Summaries are generated and may contain mistakes; the official description above is the record.
