CVE-2016-8529 Command injection in StoreVirtual 4000 Storage and StoreVirtual VSA Software running LeftHand OS

High 7.6 Published Updated

Remote attackers can execute arbitrary commands on HPE StoreVirtual storage systems, requiring an upgrade to LeftHand OS v12.6 or later.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
None listed

What is CVE-2016-8529?

CVE-2016-8529 is a high-severity command injection vulnerability in Hewlett Packard Enterprise StoreVirtual 4000 Storage and StoreVirtual VSA Software running LeftHand OS, published on 15 Feb 2018. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

A Remote Arbitrary Command Execution vulnerability in HPE StoreVirtual 4000 Storage and StoreVirtual VSA Software running LeftHand OS version v12.5 and earlier was found. The problem was resolved in LeftHand OS v12.6 or any subsequent version.

Weakness: CWE-284

Which versions are affected by CVE-2016-8529?

It affects 1 product.

Products include Hp Lefthand.

How do I fix CVE-2016-8529?

No fix has been published for CVE-2016-8529 yet. Limit exposure of the affected software until one is available.

Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.

Is CVE-2016-8529 being exploited?

There is no known exploitation of CVE-2016-8529 in the wild and no public exploit code.

Sources

Also known as GHSA-jv3r-pq8f-h2w3.

Is CVE-2016-8529 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free