CVE-2016-8579 Denial of Service in docker2aci

Medium 4.0 Published Updated

An attacker can cause a denial of service via an infinite loop in docker2aci by providing local images with cyclic dependencies.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2016-8579?

CVE-2016-8579 is a medium-severity denial of service vulnerability in n/a, published on 28 Oct 2016. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

docker2aci <= 0.12.3 has an infinite loop when handling local images with cyclic dependency chain.

Weakness: CWE-399, CWE-20

Which versions are affected by CVE-2016-8579?

3 open source packages ship an affected version, including github.com/appc/docker2aci. It affects 1 product.

PackageAffectedFixed in
github.com/appc/docker2aci GoAll versions0.13.0
github.com/appc/docker2aci GoAll versions0.13.0
github.com/appc/docker2aci GoAll versions0.13.0

Products include Docker2aci Project Docker2aci.

How do I fix CVE-2016-8579?

Upgrade github.com/appc/docker2aci to 0.13.0 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2016-8579 being exploited?

There is no known exploitation of CVE-2016-8579 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2016-8579, GHSA-gfh2-7jg5-653p, GO-2022-0833, UBUNTU-CVE-2016-8579.

Is CVE-2016-8579 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free