# CVE-2016-8579: Denial of Service in docker2aci

> An attacker can cause a denial of service via an infinite loop in docker2aci by providing local images with cyclic dependencies.

- **Severity:** Medium 4.0 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Oct 2016
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-8579, GHSA-gfh2-7jg5-653p, GO-2022-0833, UBUNTU-CVE-2016-8579

## What is CVE-2016-8579?

CVE-2016-8579 is a medium-severity denial of service vulnerability in n/a, published on 28 Oct 2016. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

docker2aci <= 0.12.3 has an infinite loop when handling local images with cyclic dependency chain.

Weakness: CWE-399, CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-8579?

3 open source packages ship an affected version, including github.com/appc/docker2aci. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/appc/docker2aci` | Go | All versions | 0.13.0 |
| `github.com/appc/docker2aci` | Go | All versions | 0.13.0 |
| `github.com/appc/docker2aci` | Go | All versions | 0.13.0 |

Products: Docker2aci Project Docker2aci.

## How do I fix CVE-2016-8579?

Upgrade github.com/appc/docker2aci to 0.13.0 or later.

## Is CVE-2016-8579 being exploited?

There is no known exploitation of CVE-2016-8579 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2016-7569](https://insights.sbomify.com/CVE-2016-7569/): Path traversal in n/a (medium 5.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8579 and fix it if it is affected.

What it is: CVE-2016-8579 is a medium-severity denial of service vulnerability in n/a, published on 28 Oct 2016. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8579 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/appc/docker2aci (Go): affected all versions; fixed in 0.13.0
- github.com/appc/docker2aci (Go): affected all versions; fixed in 0.13.0
- github.com/appc/docker2aci (Go): affected all versions; fixed in 0.13.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8579/ (Markdown: https://insights.sbomify.com/CVE-2016-8579/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8579
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8579
- OSV: https://osv.dev/vulnerability/CVE-2016-8579

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8579/
Summaries are generated and may contain mistakes; the official description above is the record.
