{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8602 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-8602 is a high-severity memory corruption vulnerability in Artifex Ghostscript, published on 14 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-8602 and fix it if it is affected.\n\nWhat it is: CVE-2016-8602 is a high-severity memory corruption vulnerability in Artifex Ghostscript, published on 14 Apr 2017. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-8602 in the wild and no public exploit code.\n\nAffected product: Artifex Ghostscript. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8602/ (Markdown: https://insights.sbomify.com/CVE-2016-8602/index.md)","id":"CVE-2016-8602","markdown":"https://insights.sbomify.com/CVE-2016-8602/index.md","name":"CVE-2016-8602","record":{"aliases":["DEBIAN-CVE-2016-8602","GHSA-m22m-c5xc-v6jq","SUSE-SU-2016:2654-1","SUSE-SU-2016:2723-1","UBUNTU-CVE-2016-8602"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Ghostscript PostScript interpreter","requires_auth":"none","summary":"Remote attackers can cause application crashes or execute arbitrary code via a crafted PostScript document exploiting a stack handling error in Ghostscript.","user_interaction":"required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ghostscript","vendor":"artifex"}],"cvss":{"score":7.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-704","name":"Incorrect Type Conversion or Cast"}],"description":"The .sethalftone5 function in psi/zht2.c in Ghostscript before 9.21 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Postscript document that calls .sethalftone5 with an empty operand stack.","ecosystems":["SUSE:Linux Enterprise Desktop 12 SP1","SUSE:Linux Enterprise Server 11 SP4","SUSE:Linux Enterprise Server 12 SP1","SUSE:Linux Enterprise Server for SAP Applications 11 SP4","SUSE:Linux Enterprise Server for SAP Applications 12 SP1","SUSE:Linux Enterprise Software Development Kit 11 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Memory corruption in n/a","id":"CVE-2016-8602","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"artifex:ghostscript","products":["artifex:ghostscript"],"type":"memory_corruption","year":"2016"},"n_packages":7,"n_references":11,"next":{"headline":"Race condition in n/a","id":"CVE-2016-8605"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Desktop 12 SP1","fixed":["9.15-14.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Desktop%2012%20SP1","source":"SUSE-SU-2016:2654-1"},{"ecosystem":"SUSE:Linux Enterprise Server 11 SP4","fixed":["8.62-32.41.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript-library","purl":"pkg:rpm/suse/ghostscript-library\u0026distro=SUSE%20Linux%20Enterprise%20Server%2011%20SP4","source":"SUSE-SU-2016:2723-1"},{"ecosystem":"SUSE:Linux Enterprise Server 12 SP1","fixed":["9.15-14.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP1","source":"SUSE-SU-2016:2654-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 11 SP4","fixed":["8.62-32.41.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript-library","purl":"pkg:rpm/suse/ghostscript-library\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2011%20SP4","source":"SUSE-SU-2016:2723-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP1","fixed":["9.15-14.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP1","source":"SUSE-SU-2016:2654-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 11 SP4","fixed":["8.62-32.41.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript-library","purl":"pkg:rpm/suse/ghostscript-library\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2011%20SP4","source":"SUSE-SU-2016:2723-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP1","fixed":["9.15-14.1"],"introduced":["0"],"last_affected":[],"package":"ghostscript","purl":"pkg:rpm/suse/ghostscript\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP1","source":"SUSE-SU-2016:2654-1"}],"prev":{"headline":"DO NOT USE THIS CANDIDATE NUMBER.","id":"CVE-2016-8601"},"products":["n/a"],"published":"2017-04-14","related":[{"cvss_score":7.8,"headline":"Artifex Ghostscript Type Confusion","id":"CVE-2017-8291","kev_date_added":"2022-05-24","published":"2017-04-27"},{"cvss_score":9.9,"headline":"Command injection in ghostscript","id":"CVE-2021-3781","kev_date_added":null,"published":"2022-02-16"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27831","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27832","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Memory corruption in n/a","id":"CVE-2025-27836","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"An issue was discovered in Artifex Ghostscript before 10.05.0.","id":"CVE-2025-27837","kev_date_added":null,"published":"2025-03-25"},{"cvss_score":9.8,"headline":"Use after free in n/a","id":"CVE-2020-36773","kev_date_added":null,"published":"2024-02-04"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["n/a"]},"summary":"Remote attackers can cause application crashes or execute arbitrary code via a crafted PostScript document exploiting a stack handling error in Ghostscript.","url":"https://insights.sbomify.com/CVE-2016-8602/"}