# CVE-2016-8609: Improper Authentication in org.keycloak:keycloak-core

> Attackers can hijack user sessions via phishing URLs due to flawed authentication flow implementation in Keycloak.

- **Severity:** Low 3.7 (`CVSS:3.0/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Aug 2018
- **Updated:** 6 Aug 2024
- **Also known as:** GHSA-95m6-mjh3-58gm

## What is CVE-2016-8609?

CVE-2016-8609 is a low-severity authentication bypass vulnerability in Redhat Keycloak, published on 1 Aug 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

It was found that the keycloak before 2.3.0 did not implement authentication flow correctly. An attacker could use this flaw to construct a phishing URL, from which he could hijack the user's session. This could lead to information disclosure, or permit further possible attacks.

Weakness: CWE-287 (Improper Authentication), CWE-384 (Session Fixation)

## Which versions are affected by CVE-2016-8609?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.3.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.3.0 |

Products: Redhat Keycloak.

## How do I fix CVE-2016-8609?

Upgrade org.keycloak:keycloak-core to 2.3.0 or later.

## Is CVE-2016-8609 being exploited?

There is no known exploitation of CVE-2016-8609 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8609 and fix it if it is affected.

What it is: CVE-2016-8609 is a low-severity authentication bypass vulnerability in Redhat Keycloak, published on 1 Aug 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-8609 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.3.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8609/ (Markdown: https://insights.sbomify.com/CVE-2016-8609/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8609
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8609
- OSV: https://osv.dev/vulnerability/CVE-2016-8609

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8609/
Summaries are generated and may contain mistakes; the official description above is the record.
