{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8614 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.2.0.0 or later.","what":"CVE-2016-8614 is a medium-severity vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-8614 and fix it if it is affected.\n\nWhat it is: CVE-2016-8614 is a medium-severity vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-8614 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.2.0.0\n- ansible (PyPI): affected all versions; fixed in 2.2.0.0\n- ansible (PyPI): affected all versions; fixed in 2.2.0.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8614/ (Markdown: https://insights.sbomify.com/CVE-2016-8614/index.md)","id":"CVE-2016-8614","markdown":"https://insights.sbomify.com/CVE-2016-8614/index.md","name":"CVE-2016-8614","record":{"aliases":["CLSA-2025-1744116044","DEBIAN-CVE-2016-8614","GHSA-cmwx-9m2h-x7v4","PYSEC-2018-37","UBUNTU-CVE-2016-8614"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible automation tool","requires_auth":"none","summary":"Attackers can inject malicious OpenPGP keys by exploiting weak fingerprint verification in the Ansible apt_key module, potentially leading to code execution.","user_interaction":"required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible","vendor":"redhat"}],"cvss":{"score":6.3,"severity":"medium","source":"cna","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L","version":"3.0"},"cwes":[{"id":"CWE-320","name":null},{"id":"CWE-358","name":"Improperly Implemented Security Check for Standard"}],"description":"A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Ansible apt_key module does not properly verify key fingerprint","id":"CVE-2016-8614","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"other","year":"2016"},"n_packages":3,"n_references":5,"next":{"headline":"Other in curl","id":"CVE-2016-8615"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.0.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-cmwx-9m2h-x7v4"},{"ecosystem":"PyPI","fixed":["2.2.0.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-cmwx-9m2h-x7v4"},{"ecosystem":"PyPI","fixed":["2.2.0.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2018-37"}],"prev":{"headline":"Cross-site scripting in foreman","id":"CVE-2016-8613"},"products":["Ansible"],"published":"2018-07-31","related":[{"cvss_score":9.8,"headline":"Ansible Remote Code Execution","id":"CVE-2014-4657","kev_date_added":null,"published":"2020-02-20"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4966","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-4967","kev_date_added":null,"published":"2020-02-18"},{"cvss_score":9.8,"headline":"Ansible Insertion of Sensitive Information into Log File vulnerability","id":"CVE-2017-7550","kev_date_added":null,"published":"2017-11-21"},{"cvss_score":8.8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2014-3498","kev_date_added":null,"published":"2017-06-08"},{"cvss_score":8,"headline":"Ansible Arbitrary Code Execution","id":"CVE-2017-7466","kev_date_added":null,"published":"2018-06-22"},{"cvss_score":7.8,"headline":"Ansible Sandbox Escape via Symlink Attack","id":"CVE-2015-6240","kev_date_added":null,"published":"2017-06-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Red Hat"]},"summary":"Attackers can inject malicious OpenPGP keys by exploiting weak fingerprint verification in the Ansible apt_key module, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2016-8614/"}