# CVE-2016-8614: Ansible apt_key module does not properly verify key fingerprint

> Attackers can inject malicious OpenPGP keys by exploiting weak fingerprint verification in the Ansible apt_key module, potentially leading to code execution.

- **Severity:** Medium 6.3 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2018
- **Updated:** 6 Aug 2024
- **Also known as:** CLSA-2025-1744116044, DEBIAN-CVE-2016-8614, GHSA-cmwx-9m2h-x7v4, PYSEC-2018-37, UBUNTU-CVE-2016-8614

## What is CVE-2016-8614?

CVE-2016-8614 is a medium-severity vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Ansible before version 2.2.0. The apt_key module does not properly verify key fingerprints, allowing remote adversary to create an OpenPGP key which matches the short key ID and inject this key instead of the correct key.

Weakness: CWE-320, CWE-358 (Improperly Implemented Security Check for Standard)

## Which versions are affected by CVE-2016-8614?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.2.0.0 |
| `ansible` | PyPI | All versions | 2.2.0.0 |
| `ansible` | PyPI | All versions | 2.2.0.0 |

Products: Redhat Ansible.

## How do I fix CVE-2016-8614?

Upgrade ansible to 2.2.0.0 or later.

## Is CVE-2016-8614 being exploited?

There is no known exploitation of CVE-2016-8614 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat Ansible

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8614 and fix it if it is affected.

What it is: CVE-2016-8614 is a medium-severity vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-8614 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.2.0.0
- ansible (PyPI): affected all versions; fixed in 2.2.0.0
- ansible (PyPI): affected all versions; fixed in 2.2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8614/ (Markdown: https://insights.sbomify.com/CVE-2016-8614/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8614
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8614
- OSV: https://osv.dev/vulnerability/CVE-2016-8614

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8614/
Summaries are generated and may contain mistakes; the official description above is the record.
