# CVE-2016-8628: Ansible fails to properly sanitize fact variables sent from the Ansible controller

> Attackers can execute arbitrary commands on Ansible clients by sending unsanitized fact variables from the controller.

- **Severity:** High 7.6 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-8628, GHSA-jg4f-jqm5-4mgq, PYSEC-2018-38, RHSA-2016:2778, UBUNTU-CVE-2016-8628

## What is CVE-2016-8628?

CVE-2016-8628 is a high-severity command injection vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Ansible before version 2.2.0 fails to properly sanitize fact variables sent from the Ansible controller. An attacker with the ability to create special variables on the controller could execute arbitrary commands on Ansible clients as the user Ansible runs as.

Weakness: CWE-77 (Improper Neutralization of Special Elements used in a Command)

## Which versions are affected by CVE-2016-8628?

3 open source packages ship an affected version, including ansible. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.2.0.0 |
| `ansible` | PyPI | All versions | 2.2.0.0 |
| `ansible` | PyPI | All versions | 2.2.0.0 |
| `ansible` | Red Hat:openshift:3.2::el7 | All versions | 0:2.2.0.0-1.el7 |
| `atomic-openshift-utils` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible-docs` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible-filter-plugins` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible-lookup-plugins` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible-playbooks` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `openshift-ansible-roles` | Red Hat:openshift:3.2::el7 | All versions | 0:3.2.42-1.git.0.6b09be9.el7 |
| `ansible` | Red Hat:openshift:3.3::el7 | All versions | 0:2.2.0.0-1.el7 |
| `atomic-openshift-utils` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-callback-plugins` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-docs` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-filter-plugins` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-lookup-plugins` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-playbooks` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |
| `openshift-ansible-roles` | Red Hat:openshift:3.3::el7 | All versions | 0:3.3.50-1.git.0.5bdbeaa.el7 |

Products: Redhat Ansible.

## How do I fix CVE-2016-8628?

Upgrade ansible to 2.2.0.0 or later.

## Is CVE-2016-8628 being exploited?

There is no known exploitation of CVE-2016-8628 in the wild and no public exploit code.

## Other vulnerabilities in Red Hat Ansible

- [CVE-2014-4657](https://insights.sbomify.com/CVE-2014-4657/): Ansible Remote Code Execution (critical 9.8)
- [CVE-2014-4966](https://insights.sbomify.com/CVE-2014-4966/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2014-4967](https://insights.sbomify.com/CVE-2014-4967/): Ansible Arbitrary Code Execution (critical 9.8)
- [CVE-2017-7550](https://insights.sbomify.com/CVE-2017-7550/): Ansible Insertion of Sensitive Information into Log File vulnerability (critical 9.8)
- [CVE-2014-3498](https://insights.sbomify.com/CVE-2014-3498/): Ansible Arbitrary Code Execution (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8628 and fix it if it is affected.

What it is: CVE-2016-8628 is a high-severity command injection vulnerability in Red Hat Ansible, published on 31 Jul 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-8628 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.2.0.0
- ansible (PyPI): affected all versions; fixed in 2.2.0.0
- ansible (PyPI): affected all versions; fixed in 2.2.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8628/ (Markdown: https://insights.sbomify.com/CVE-2016-8628/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8628
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8628
- OSV: https://osv.dev/vulnerability/CVE-2016-8628

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8628/
Summaries are generated and may contain mistakes; the official description above is the record.
