{"answers":{"affected":"2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-8629 in the wild and no public exploit code.","fix":"Upgrade org.keycloak:keycloak-core to 2.4.0 or later.","what":"CVE-2016-8629 is a medium-severity missing authorization vulnerability in Redhat Keycloak, published on 12 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-8629 and fix it if it is affected.\n\nWhat it is: CVE-2016-8629 is a medium-severity missing authorization vulnerability in Redhat Keycloak, published on 12 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-8629 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.4.0\n- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.4.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8629/ (Markdown: https://insights.sbomify.com/CVE-2016-8629/index.md)","id":"CVE-2016-8629","markdown":"https://insights.sbomify.com/CVE-2016-8629/index.md","name":"CVE-2016-8629","record":{"aliases":["GHSA-778x-2mqv-w6xw"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_modify","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity and Access Management","requires_auth":"low_privilege","summary":"Attackers with service account authentication can bypass permissions to delete users in separate realms, requiring an upgrade to Keycloak.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"keycloak","vendor":"redhat"},{"product":"single_sign_on","vendor":"redhat"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-264","name":null},{"id":"CWE-284","name":"Improper Access Control"}],"description":"Red Hat Keycloak before version 2.4.0 did not correctly check permissions when handling service account user deletion requests sent to the rest server. An attacker with service account authentication could use this flaw to bypass normal permissions and delete users in a separate realm.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects org.keycloak:keycloak-core","id":"CVE-2016-8629","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"redhat:keycloak","products":["redhat:keycloak"],"type":"missing_authorization","year":"2016"},"n_packages":2,"n_references":6,"next":{"headline":"Denial of service in n/a","id":"CVE-2016-8630"},"packages":[{"ecosystem":"Maven","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"org.keycloak:keycloak-core","purl":null,"source":"GHSA-778x-2mqv-w6xw"},{"ecosystem":"Maven","fixed":["2.4.0"],"introduced":["0"],"last_affected":[],"package":"org.keycloak:keycloak-core","purl":"pkg:maven/org.keycloak/keycloak-core","source":"GHSA-778x-2mqv-w6xw"}],"prev":{"headline":"Ansible fails to properly sanitize fact variables sent from the Ansible controller","id":"CVE-2016-8628"},"products":["Keycloak"],"published":"2018-03-12","related":[{"cvss_score":10,"headline":"Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC","id":"CVE-2022-4361","kev_date_added":null,"published":"2023-07-07"},{"cvss_score":9.8,"headline":"Keycloak vulnerable to privilege escalation on Token Exchange feature","id":"CVE-2022-1245","kev_date_added":null,"published":"2022-07-07"},{"cvss_score":9.6,"headline":"keycloak Self Stored Cross-site Scripting vulnerability","id":"CVE-2021-20195","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.3,"headline":"Keycloak Authentication Error","id":"CVE-2019-14910","kev_date_added":null,"published":"2019-12-05"},{"cvss_score":9.3,"headline":"Keycloak Authentication Error","id":"CVE-2019-14909","kev_date_added":null,"published":"2019-12-04"},{"cvss_score":9.1,"headline":"Keycloak vulnerable to path traversal via double URL encoding","id":"CVE-2022-3782","kev_date_added":null,"published":"2023-01-11"},{"cvss_score":9.1,"headline":"keycloak vulnerable to unauthorized login via mail server setup","id":"CVE-2019-14837","kev_date_added":null,"published":"2020-01-07"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["Red Hat, Inc."]},"summary":"Attackers with service account authentication can bypass permissions to delete users in separate realms, requiring an upgrade to Keycloak.","url":"https://insights.sbomify.com/CVE-2016-8629/"}