# CVE-2016-8629: Moderate severity vulnerability that affects org.keycloak:keycloak-core

> Attackers with service account authentication can bypass permissions to delete users in separate realms, requiring an upgrade to Keycloak.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Mar 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-778x-2mqv-w6xw

## What is CVE-2016-8629?

CVE-2016-8629 is a medium-severity missing authorization vulnerability in Redhat Keycloak, published on 12 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Red Hat Keycloak before version 2.4.0 did not correctly check permissions when handling service account user deletion requests sent to the rest server. An attacker with service account authentication could use this flaw to bypass normal permissions and delete users in a separate realm.

Weakness: CWE-264, CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2016-8629?

2 open source packages ship an affected version, including org.keycloak:keycloak-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.4.0 |
| `org.keycloak:keycloak-core` | Maven | All versions | 2.4.0 |

Products: Redhat Keycloak, Redhat Single Sign On.

## How do I fix CVE-2016-8629?

Upgrade org.keycloak:keycloak-core to 2.4.0 or later.

## Is CVE-2016-8629 being exploited?

There is no known exploitation of CVE-2016-8629 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Keycloak

- [CVE-2022-4361](https://insights.sbomify.com/CVE-2022-4361/): Keycloak vulnerable to cross-site scripting when validating URI-schemes on SAML and OIDC (critical 10.0)
- [CVE-2022-1245](https://insights.sbomify.com/CVE-2022-1245/): Keycloak vulnerable to privilege escalation on Token Exchange feature (critical 9.8)
- [CVE-2021-20195](https://insights.sbomify.com/CVE-2021-20195/): keycloak Self Stored Cross-site Scripting vulnerability (critical 9.6)
- [CVE-2019-14910](https://insights.sbomify.com/CVE-2019-14910/): Keycloak Authentication Error (critical 9.3)
- [CVE-2019-14909](https://insights.sbomify.com/CVE-2019-14909/): Keycloak Authentication Error (critical 9.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8629 and fix it if it is affected.

What it is: CVE-2016-8629 is a medium-severity missing authorization vulnerability in Redhat Keycloak, published on 12 Mar 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8629 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.4.0
- org.keycloak:keycloak-core (Maven): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8629/ (Markdown: https://insights.sbomify.com/CVE-2016-8629/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8629
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8629
- OSV: https://osv.dev/vulnerability/CVE-2016-8629

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8629/
Summaries are generated and may contain mistakes; the official description above is the record.
