# CVE-2016-8638: Session Fixation in ipsilon

> An unauthenticated attacker can view and terminate active sessions of other users in Ipsilon, causing denial of service and bypassing session security.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 12 Jul 2017
- **Updated:** 6 Aug 2024
- **Also known as:** CVE-2017-16855, GHSA-376m-3rm2-9jm6, PYSEC-2026-360, RHSA-2016:2809

## What is CVE-2016-8638?

CVE-2016-8638 is a critical authentication bypass vulnerability in n/a, published on 12 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A vulnerability in ipsilon 2.0 before 2.0.2, 1.2 before 1.2.1, 1.1 before 1.1.2, and 1.0 before 1.0.3 was found that allows attacker to log out active sessions of other users.  This issue is related to how it tracks sessions, and allows an unauthenticated attacker to view and terminate active sessions from other users. It is also called a "SAML2 multi-session vulnerability."

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2016-8638?

9 open source packages ship an affected version, including ipsilon. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ipsilon` | PyPI | From 1.0.0 | 1.0.3, 1.1.2, 2.0.2, 1.2.1 |
| `ipsilon` | PyPI | From 1.0.0 | 1.0.3 |
| `ipsilon` | PyPI | From 1.0.0 | 1.0.3 |
| `ipsilon` | PyPI | From 1.1.0 | 1.1.2 |
| `ipsilon` | PyPI | From 1.1.0 | 1.1.2 |
| `ipsilon` | PyPI | From 1.2.0 | 1.2.1 |
| `ipsilon` | PyPI | From 1.2.0 | 1.2.1 |
| `ipsilon` | PyPI | From 2.0.0 | 2.0.2 |
| `ipsilon` | PyPI | From 2.0.0 | 2.0.2 |
| `ipsilon` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-authform` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-authgssapi` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-authldap` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-base` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-client` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-filesystem` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-infosssd` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-persona` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-saml2` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-saml2-base` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |
| `ipsilon-tools-ipa` | Red Hat:enterprise_linux:7::server | All versions | 0:1.0.0-13.el7_3 |

Products: Ipsilon Project Ipsilon.

## How do I fix CVE-2016-8638?

Upgrade ipsilon to a fixed version for your release line: 1.0.3, 1.1.2, 2.0.2 or 1.2.1.

## Is CVE-2016-8638 being exploited?

There is no known exploitation of CVE-2016-8638 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2015-5301](https://insights.sbomify.com/CVE-2015-5301/): Ipsilon denial of service by deleting a SAML2 Service Provider (SP) (medium 5.5)
- [CVE-2015-5217](https://insights.sbomify.com/CVE-2015-5217/): Ipsilon denial of service via a duplicate SP name (medium 4.0)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8638 and fix it if it is affected.

What it is: CVE-2016-8638 is a critical authentication bypass vulnerability in n/a, published on 12 Jul 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8638 in the wild and no public exploit code.

Affected packages and fixed versions:
- ipsilon (PyPI): affected from 1.0.0; fixed in 1.0.3, 1.1.2, 2.0.2, 1.2.1
- ipsilon (PyPI): affected from 1.0.0; fixed in 1.0.3
- ipsilon (PyPI): affected from 1.0.0; fixed in 1.0.3
- ipsilon (PyPI): affected from 1.1.0; fixed in 1.1.2
- ipsilon (PyPI): affected from 1.1.0; fixed in 1.1.2
- ipsilon (PyPI): affected from 1.2.0; fixed in 1.2.1
- ipsilon (PyPI): affected from 1.2.0; fixed in 1.2.1
- ipsilon (PyPI): affected from 2.0.0; fixed in 2.0.2
- ipsilon (PyPI): affected from 2.0.0; fixed in 2.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8638/ (Markdown: https://insights.sbomify.com/CVE-2016-8638/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8638
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8638
- OSV: https://osv.dev/vulnerability/CVE-2016-8638

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8638/
Summaries are generated and may contain mistakes; the official description above is the record.
