{"answers":{"affected":"7 open source packages ship an affected version, including pycsw. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8640 in the wild and no public exploit code.","fix":"Upgrade pycsw to a fixed version for your release line: 1.8.6, 1.10.5 or 2.0.2.","what":"CVE-2016-8640 is a critical SQL injection vulnerability in https://github.com/geopython pycsw, published on 1 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-8640 and fix it if it is affected.\n\nWhat it is: CVE-2016-8640 is a critical SQL injection vulnerability in https://github.com/geopython pycsw, published on 1 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-8640 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pycsw (PyPI): affected all versions; fixed in 1.8.6, 1.10.5, 2.0.2\n- pycsw (PyPI): affected all versions; fixed in 1.8.6\n- pycsw (PyPI): affected all versions; fixed in 1.8.6\n- pycsw (PyPI): affected from 1.10.0; fixed in 1.10.5\n- pycsw (PyPI): affected from 1.10.0; fixed in 1.10.5\n- pycsw (PyPI): affected from 2.0.0; fixed in 2.0.2\n- pycsw (PyPI): affected from 2.0.0; fixed in 2.0.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8640/ (Markdown: https://insights.sbomify.com/CVE-2016-8640/index.md)","id":"CVE-2016-8640","markdown":"https://insights.sbomify.com/CVE-2016-8640/index.md","name":"CVE-2016-8640","record":{"aliases":["DEBIAN-CVE-2016-8640","GHSA-hg4c-rgvm-964g","PYSEC-2018-98","UBUNTU-CVE-2016-8640"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"pycsw server","requires_auth":"none","summary":"SQL injection in pycsw allows attackers to read, modify, or delete database contents accessible to the database user.","user_interaction":"not_required","vuln_class":"sql_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"pycsw","vendor":"pycsw"}],"cvss":{"score":9.1,"severity":"critical","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-89","name":"Improper Neutralization of Special Elements used in an SQL Command"}],"description":"A SQL injection vulnerability in pycsw all versions before 2.0.2, 1.10.5 and 1.8.6 that leads to read and extract of any data from any table in the pycsw database that the database user has access to. Also on PostgreSQL (at least) it is possible to perform updates/inserts/deletes and database modifications to any table the database user has access to.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"SQL Injection in pycsw","id":"CVE-2016-8640","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"sql_injection","year":"2016"},"n_packages":7,"n_references":4,"next":{"headline":"Privilege escalation in nagios","id":"CVE-2016-8641"},"packages":[{"ecosystem":"PyPI","fixed":["1.8.6","1.10.5","2.0.2"],"introduced":["0","1.10.0","2.0.0"],"last_affected":[],"package":"pycsw","purl":"pkg:pypi/pycsw","source":"PYSEC-2018-98"},{"ecosystem":"PyPI","fixed":["1.8.6"],"introduced":["0"],"last_affected":[],"package":"pycsw","purl":null,"source":"GHSA-hg4c-rgvm-964g"},{"ecosystem":"PyPI","fixed":["1.8.6"],"introduced":["0"],"last_affected":[],"package":"pycsw","purl":"pkg:pypi/pycsw","source":"GHSA-hg4c-rgvm-964g"},{"ecosystem":"PyPI","fixed":["1.10.5"],"introduced":["1.10.0"],"last_affected":[],"package":"pycsw","purl":null,"source":"GHSA-hg4c-rgvm-964g"},{"ecosystem":"PyPI","fixed":["1.10.5"],"introduced":["1.10.0"],"last_affected":[],"package":"pycsw","purl":"pkg:pypi/pycsw","source":"GHSA-hg4c-rgvm-964g"},{"ecosystem":"PyPI","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"pycsw","purl":null,"source":"GHSA-hg4c-rgvm-964g"},{"ecosystem":"PyPI","fixed":["2.0.2"],"introduced":["2.0.0"],"last_affected":[],"package":"pycsw","purl":"pkg:pypi/pycsw","source":"GHSA-hg4c-rgvm-964g"}],"prev":{"headline":"Cross-site scripting in foreman","id":"CVE-2016-8639"},"products":["pycsw"],"published":"2018-08-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["https://github.com/geopython"]},"summary":"SQL injection in pycsw allows attackers to read, modify, or delete database contents accessible to the database user.","url":"https://insights.sbomify.com/CVE-2016-8640/"}