CVE-2016-8642 Moodle Unauthenticated Access
Attackers can access unauthorized files in Moodle's question engine due to missing authorization checks, exposing sensitive data.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2016-8642?
CVE-2016-8642 is a medium-severity missing authorization vulnerability in Moodle Moodle, published on 20 Jan 2017. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
In Moodle 2.x and 3.x, the question engine allows access to files that should not be available.
Weakness: CWE-284
Which versions are affected by CVE-2016-8642?
10 open source packages ship an affected version, including moodle/moodle. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
moodle/moodle Packagist | From 2.7.0 | 2.7.17 |
moodle/moodle Packagist | From 2.7.0 | 2.7.17 |
moodle/moodle Packagist | From 2.8.0 to 2.8.12 | None |
moodle/moodle Packagist | From 2.8.0 to 2.8.12 | None |
moodle/moodle Packagist | From 2.9.0 | 2.9.9 |
moodle/moodle Packagist | From 2.9.0 | 2.9.9 |
4 more packages
moodle/moodle Packagist | From 3.0.0 | 3.0.7 |
moodle/moodle Packagist | From 3.0.0 | 3.0.7 |
moodle/moodle Packagist | From 3.1.0 | 3.1.3 |
moodle/moodle Packagist | From 3.1.0 | 3.1.3 |
Products include Moodle Moodle.
How do I fix CVE-2016-8642?
Upgrade moodle/moodle to a fixed version for your release line: 2.7.17, 2.9.9, 3.0.7 or 3.1.3.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2016-8642 being exploited?
There is no known exploitation of CVE-2016-8642 in the wild and no public exploit code.
Other vulnerabilities in Moodle Moodle
- CVE-2006-4935 File upload in n/a
- CVE-2006-4936 Moodle does not properly validate module instance id
- CVE-2004-2233 Unknown "front page vulnerability with Moodle servers" for Moodle before 1.3.2 has unknown impact and attack vectors.
- CVE-2004-2235 Cross-site scripting in n/a
- CVE-2004-2236 Other in n/a
Sources
Also known as GHSA-x32v-7qw8-cpq8, UBUNTU-CVE-2016-8642.