{"answers":{"affected":"3 open source packages ship an affected version, including ansible. It affects 2 products.","exploited":"There is no known exploitation of CVE-2016-8647 in the wild and no public exploit code.","fix":"Upgrade ansible to 2.2.1.0 or later.","what":"CVE-2016-8647 is a low-severity vulnerability in Redhat Virtualization, published on 26 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-8647 and fix it if it is affected.\n\nWhat it is: CVE-2016-8647 is a low-severity vulnerability in Redhat Virtualization, published on 26 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-8647 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- ansible (PyPI): affected all versions; fixed in 2.2.1.0\n- ansible (PyPI): affected all versions; fixed in 2.2.1.0\n- ansible (PyPI): affected all versions; fixed in 2.2.1.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8647/ (Markdown: https://insights.sbomify.com/CVE-2016-8647/index.md)","id":"CVE-2016-8647","markdown":"https://insights.sbomify.com/CVE-2016-8647/index.md","name":"CVE-2016-8647","record":{"aliases":["DEBIAN-CVE-2016-8647","GHSA-x4cm-m36h-c6qj","PYSEC-2018-58"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Ansible MySQL module","requires_auth":"high_privilege","summary":"Ansible's mysql_user module may fail to update passwords, leaving old credentials active and allowing unauthorized access.","user_interaction":"not_required","vuln_class":"business_logic"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"redhat","cpe":[{"product":"ansible_engine","vendor":"redhat"},{"product":"virtualization","vendor":"redhat"}],"cvss":{"score":2.2,"severity":"low","source":"cna","vector":"CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Improper Input Validation in ansible","id":"CVE-2016-8647","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"redhat:virtualization","products":["redhat:virtualization"],"type":"business_logic","year":"2016"},"n_packages":3,"n_references":3,"next":{"headline":"Deserialization in Karaf","id":"CVE-2016-8648"},"packages":[{"ecosystem":"PyPI","fixed":["2.2.1.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":null,"source":"GHSA-x4cm-m36h-c6qj"},{"ecosystem":"PyPI","fixed":["2.2.1.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"GHSA-x4cm-m36h-c6qj"},{"ecosystem":"PyPI","fixed":["2.2.1.0"],"introduced":["0"],"last_affected":[],"package":"ansible","purl":"pkg:pypi/ansible","source":"PYSEC-2018-58"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2016-8646"},"products":["Ansible"],"published":"2018-07-26","related":[{"cvss_score":7.8,"headline":"Ansible Improper Input Validation vulnerability","id":"CVE-2018-10874","kev_date_added":null,"published":"2018-07-02"},{"cvss_score":7.5,"headline":"Path Traversal in Ansible","id":"CVE-2020-1737","kev_date_added":null,"published":"2020-03-09"},{"cvss_score":7.4,"headline":"OS Command Injection in ansible","id":"CVE-2020-1734","kev_date_added":null,"published":"2020-03-03"},{"cvss_score":7.3,"headline":"Ansible leaks sensitive information to logs when told not to","id":"CVE-2019-14858","kev_date_added":null,"published":"2019-10-14"},{"cvss_score":5.2,"headline":"Path Traversal in Ansible","id":"CVE-2020-10691","kev_date_added":null,"published":"2020-04-30"},{"cvss_score":4.2,"headline":"Ansible Logs Passwords If PowerShell ScriptBlock is Enabled","id":"CVE-2018-16859","kev_date_added":null,"published":"2018-11-29"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Red Hat"]},"summary":"Ansible's mysql_user module may fail to update passwords, leaving old credentials active and allowing unauthorized access.","url":"https://insights.sbomify.com/CVE-2016-8647/"}