# CVE-2016-8647: Improper Input Validation in ansible

> Ansible's mysql_user module may fail to update passwords, leaving old credentials active and allowing unauthorized access.

- **Severity:** Low 2.2 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jul 2018
- **Updated:** 6 Aug 2024
- **Also known as:** DEBIAN-CVE-2016-8647, GHSA-x4cm-m36h-c6qj, PYSEC-2018-58

## What is CVE-2016-8647?

CVE-2016-8647 is a low-severity vulnerability in Redhat Virtualization, published on 26 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

An input validation vulnerability was found in Ansible's mysql_user module before 2.2.1.0, which may fail to correctly change a password in certain circumstances. Thus the previous password would still be active when it should have been changed.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2016-8647?

3 open source packages ship an affected version, including ansible. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ansible` | PyPI | All versions | 2.2.1.0 |
| `ansible` | PyPI | All versions | 2.2.1.0 |
| `ansible` | PyPI | All versions | 2.2.1.0 |

Products: Redhat Ansible Engine, Redhat Virtualization.

## How do I fix CVE-2016-8647?

Upgrade ansible to 2.2.1.0 or later.

## Is CVE-2016-8647 being exploited?

There is no known exploitation of CVE-2016-8647 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Virtualization

- [CVE-2018-10874](https://insights.sbomify.com/CVE-2018-10874/): Ansible Improper Input Validation vulnerability (high 7.8)
- [CVE-2020-1737](https://insights.sbomify.com/CVE-2020-1737/): Path Traversal in Ansible (high 7.5)
- [CVE-2020-1734](https://insights.sbomify.com/CVE-2020-1734/): OS Command Injection in ansible (high 7.4)
- [CVE-2019-14858](https://insights.sbomify.com/CVE-2019-14858/): Ansible leaks sensitive information to logs when told not to (high 7.3)
- [CVE-2020-10691](https://insights.sbomify.com/CVE-2020-10691/): Path Traversal in Ansible (medium 5.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8647 and fix it if it is affected.

What it is: CVE-2016-8647 is a low-severity vulnerability in Redhat Virtualization, published on 26 Jul 2018. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2016-8647 in the wild and no public exploit code.

Affected packages and fixed versions:
- ansible (PyPI): affected all versions; fixed in 2.2.1.0
- ansible (PyPI): affected all versions; fixed in 2.2.1.0
- ansible (PyPI): affected all versions; fixed in 2.2.1.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8647/ (Markdown: https://insights.sbomify.com/CVE-2016-8647/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8647
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8647
- OSV: https://osv.dev/vulnerability/CVE-2016-8647

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8647/
Summaries are generated and may contain mistakes; the official description above is the record.
