{"answers":{"affected":"4 open source packages ship an affected version, including org.apache.brooklyn:brooklyn-jsgui and org.apache.brooklyn:brooklyn-rest-resources. It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8737 in the wild and no public exploit code.","fix":"Upgrade org.apache.brooklyn:brooklyn-jsgui to 0.10.0 or later.","what":"CVE-2016-8737 is a high-severity vulnerability in Apache Brooklyn, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2016-8737 and fix it if it is affected.\n\nWhat it is: CVE-2016-8737 is a high-severity vulnerability in Apache Brooklyn, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2016-8737 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.apache.brooklyn:brooklyn-jsgui (Maven): affected all versions; fixed in 0.10.0\n- org.apache.brooklyn:brooklyn-jsgui (Maven): affected all versions; fixed in 0.10.0\n- org.apache.brooklyn:brooklyn-rest-resources (Maven): affected all versions; fixed in 0.10.0\n- org.apache.brooklyn:brooklyn-rest-resources (Maven): affected all versions; fixed in 0.10.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8737/ (Markdown: https://insights.sbomify.com/CVE-2016-8737/index.md)","id":"CVE-2016-8737","markdown":"https://insights.sbomify.com/CVE-2016-8737/index.md","name":"CVE-2016-8737","record":{"aliases":["GHSA-g2hf-g7fh-vg92"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Apache Brooklyn","requires_auth":"none","summary":"A CSRF vulnerability in Apache Brooklyn allows attackers to execute commands as logged-in users via malicious links.","user_interaction":"required","vuln_class":"csrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"brooklyn","vendor":"apache"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-352","name":"Cross-Site Request Forgery"}],"description":"In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site request forgery (CSRF), which could permit a malicious web site to produce a link which, if clicked whilst a user is logged in to Brooklyn, would cause the server to execute the attacker's commands as the user. There is known to be a proof-of-concept exploit using this vulnerability.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Apache Brooklyn is vulnerable to cross-site request forgery (CSRF)","id":"CVE-2016-8737","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"csrf","year":"2016"},"n_packages":4,"n_references":3,"next":{"headline":"Apache Struts vulnerable to possible DoS attack when using URLValidator","id":"CVE-2016-8738"},"packages":[{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn-jsgui","purl":null,"source":"GHSA-g2hf-g7fh-vg92"},{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn-jsgui","purl":"pkg:maven/org.apache.brooklyn/brooklyn-jsgui","source":"GHSA-g2hf-g7fh-vg92"},{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn-rest-resources","purl":null,"source":"GHSA-g2hf-g7fh-vg92"},{"ecosystem":"Maven","fixed":["0.10.0"],"introduced":["0"],"last_affected":[],"package":"org.apache.brooklyn:brooklyn-rest-resources","purl":"pkg:maven/org.apache.brooklyn/brooklyn-rest-resources","source":"GHSA-g2hf-g7fh-vg92"}],"prev":{"headline":"Apache OpenMeetings RCE","id":"CVE-2016-8736"},"products":["Apache Brooklyn"],"published":"2017-09-13","related":[{"cvss_score":8.8,"headline":"Deserialization of Untrusted Data in Apache Brooklyn","id":"CVE-2016-8744","kev_date_added":null,"published":"2017-09-13"},{"cvss_score":5.4,"headline":"Cross-site Scripting In Apache Brooklyn","id":"CVE-2017-3165","kev_date_added":null,"published":"2017-09-13"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["Apache Software Foundation"]},"summary":"A CSRF vulnerability in Apache Brooklyn allows attackers to execute commands as logged-in users via malicious links.","url":"https://insights.sbomify.com/CVE-2016-8737/"}