# CVE-2016-8737: Apache Brooklyn is vulnerable to cross-site request forgery (CSRF)

> A CSRF vulnerability in Apache Brooklyn allows attackers to execute commands as logged-in users via malicious links.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Sep 2017
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-g2hf-g7fh-vg92

## What is CVE-2016-8737?

CVE-2016-8737 is a high-severity vulnerability in Apache Brooklyn, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

In Apache Brooklyn before 0.10.0, the REST server is vulnerable to cross-site request forgery (CSRF), which could permit a malicious web site to produce a link which, if clicked whilst a user is logged in to Brooklyn, would cause the server to execute the attacker's commands as the user. There is known to be a proof-of-concept exploit using this vulnerability.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2016-8737?

4 open source packages ship an affected version, including org.apache.brooklyn:brooklyn-jsgui and org.apache.brooklyn:brooklyn-rest-resources. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.brooklyn:brooklyn-jsgui` | Maven | All versions | 0.10.0 |
| `org.apache.brooklyn:brooklyn-jsgui` | Maven | All versions | 0.10.0 |
| `org.apache.brooklyn:brooklyn-rest-resources` | Maven | All versions | 0.10.0 |
| `org.apache.brooklyn:brooklyn-rest-resources` | Maven | All versions | 0.10.0 |

Products: Apache Brooklyn.

## How do I fix CVE-2016-8737?

Upgrade org.apache.brooklyn:brooklyn-jsgui to 0.10.0 or later.

## Is CVE-2016-8737 being exploited?

There is no known exploitation of CVE-2016-8737 in the wild and no public exploit code.

## Other vulnerabilities in Apache Brooklyn

- [CVE-2016-8744](https://insights.sbomify.com/CVE-2016-8744/): Deserialization of Untrusted Data in Apache Brooklyn (high 8.8)
- [CVE-2017-3165](https://insights.sbomify.com/CVE-2017-3165/): Cross-site Scripting In Apache Brooklyn (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2016-8737 and fix it if it is affected.

What it is: CVE-2016-8737 is a high-severity vulnerability in Apache Brooklyn, published on 13 Sep 2017. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2016-8737 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.brooklyn:brooklyn-jsgui (Maven): affected all versions; fixed in 0.10.0
- org.apache.brooklyn:brooklyn-jsgui (Maven): affected all versions; fixed in 0.10.0
- org.apache.brooklyn:brooklyn-rest-resources (Maven): affected all versions; fixed in 0.10.0
- org.apache.brooklyn:brooklyn-rest-resources (Maven): affected all versions; fixed in 0.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2016-8737/ (Markdown: https://insights.sbomify.com/CVE-2016-8737/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2016-8737
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2016-8737
- OSV: https://osv.dev/vulnerability/CVE-2016-8737

---
From sbomify Insights: https://insights.sbomify.com/CVE-2016-8737/
Summaries are generated and may contain mistakes; the official description above is the record.
