{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2016-8740 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2016-8740 is a high-severity denial of service vulnerability in Apache Http Server, published on 5 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2016-8740 and fix it if it is affected.\n\nWhat it is: CVE-2016-8740 is a high-severity denial of service vulnerability in Apache Http Server, published on 5 Dec 2016. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2016-8740 in the wild and no public exploit code.\n\nAffected product: Apache Http Server. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2016-8740/ (Markdown: https://insights.sbomify.com/CVE-2016-8740/index.md)","id":"CVE-2016-8740","markdown":"https://insights.sbomify.com/CVE-2016-8740/index.md","name":"CVE-2016-8740","record":{"aliases":["DEBIAN-CVE-2016-8740","GHSA-pfj2-72r3-p693","SUSE-SU-2017:0203-1"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":true,"product_category":"Apache HTTP Server","requires_auth":"none","summary":"Remote attackers can cause denial of service via memory consumption in Apache HTTP Server when HTTP/2 protocols are enabled.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"apache","cpe":[{"product":"http_server","vendor":"apache"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-399","name":null},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The mod_http2 module in the Apache HTTP Server 2.4.17 through 2.4.23, when the Protocols configuration includes h2 or h2c, does not restrict request-header length, which allows remote attackers to cause a denial of service (memory consumption) via crafted CONTINUATION frames in an HTTP/2 request.","ecosystems":["SUSE:Linux Enterprise Server 12 SP2","SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","SUSE:Linux Enterprise Server for SAP Applications 12 SP2","SUSE:Linux Enterprise Software Development Kit 12 SP2"],"exploits":{"exploitdb":1,"first_seen":"2016-12-12","github_poc":2,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2017-10-11T23:42:49Z","kind":"github_poc","ref":"https://github.com/lcfpadilha/mac0352-ep4","stars":1,"title":"Apache HTTP Server 2.4.23 vulnerability study (CVE-2016-8740)"},{"date":"2021-08-03T10:45:59Z","kind":"github_poc","ref":"https://github.com/jptr218/apachedos","stars":1,"title":"An implementation of CVE-2016-8740"},{"date":"2016-12-12","kind":"exploitdb","ref":"40909","stars":null,"title":"Apache 2.4.23 mod_http2 - Denial of Service"}],"tier":"poc_unverified"},"has_fix":true,"headline":"Denial of service in Apache HTTP Server","id":"CVE-2016-8740","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":"apache:http_server","products":["apache:http_server"],"type":"denial_of_service","year":"2016"},"n_packages":4,"n_references":28,"next":{"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Apache Qpid Broker for Java","id":"CVE-2016-8741"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Server 12 SP2","fixed":["2.4.23-16.3"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Server%2012%20SP2","source":"SUSE-SU-2017:0203-1"},{"ecosystem":"SUSE:Linux Enterprise Server for Raspberry Pi 12 SP2","fixed":["2.4.23-16.3"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20Raspberry%20Pi%2012%20SP2","source":"SUSE-SU-2017:0203-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP Applications 12 SP2","fixed":["2.4.23-16.3"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20Applications%2012%20SP2","source":"SUSE-SU-2017:0203-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP2","fixed":["2.4.23-16.3"],"introduced":["0"],"last_affected":[],"package":"apache2","purl":"pkg:rpm/suse/apache2\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP2","source":"SUSE-SU-2017:0203-1"}],"prev":{"headline":"Improper Restriction of XML External Entity Reference in Apache CXF JAX-RS","id":"CVE-2016-8739"},"products":["Apache HTTP Server"],"published":"2016-12-05","related":[{"cvss_score":9.8,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-42013","kev_date_added":"2021-11-03","published":"2021-10-07"},{"cvss_score":9.1,"headline":"Apache HTTP Server Improper Escaping of Output","id":"CVE-2024-38475","kev_date_added":"2025-05-01","published":"2024-07-01"},{"cvss_score":9,"headline":"Apache HTTP Server-Side Request Forgery (SSRF)","id":"CVE-2021-40438","kev_date_added":"2021-12-01","published":"2021-09-16"},{"cvss_score":7.8,"headline":"Apache HTTP Server Privilege Escalation","id":"CVE-2019-0211","kev_date_added":"2021-11-03","published":"2019-04-08"},{"cvss_score":7.5,"headline":"Apache HTTP Server Path Traversal","id":"CVE-2021-41773","kev_date_added":"2021-11-03","published":"2021-10-05"},{"cvss_score":10,"headline":"Use after free in n/a","id":"CVE-2010-0425","kev_date_added":null,"published":"2010-03-05"},{"cvss_score":10,"headline":"Auth bypass in n/a","id":"CVE-2005-2700","kev_date_added":null,"published":"2005-09-06"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"attribution","licence":"GPL-2.0-or-later","name":"Exploit-DB"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-06","vendors":["Apache Software Foundation"]},"summary":"Remote attackers can cause denial of service via memory consumption in Apache HTTP Server when HTTP/2 protocols are enabled.","url":"https://insights.sbomify.com/CVE-2016-8740/"}